Return to Level1Techs.com

Extended SMART self-test keeps aborting

I’m trying to run tests on a new drive, but the extended self-test keeps aborting after about an hour (twice now). It claims the test was manually aborted, but I swear I didn’t touch it!

The drive is in a HDD dock, connected by USB3 to my computer’s front USB port. I hope it’s not something stupid like USB powersaving.

I’ve also been doing an extended self-test on another drive (it’s a dual-slot HDD dock), and that one is still going:

Both drives tend to spin down, but the second one spins up again multiple times. I don’t know if that’s a normal part of the test or not.

One difference is the first/aborting drive is not formatted, has no filesystem or volume label, and thus isn’t mounted. Wonder if that makes any difference.

I’ve had some problems with USB 3 docks before, like doc suddenly disconnecting etc.

Have you tried to plug the HDD directly to motherboard?

No, I haven’t yet tried connecting directly to the motherboard. I was hoping to avoid that as my tower is in a tight spot and I never shut it off.

One last thing I’ll try is disabling the HDD’s Advanced Power Management with hdparm -B255 /dev/sdb and setting standby to off with hdparm -S0 /dev/sdb. Let’s see what happens.

Nothing I tried worked: changing hdparm settings, trying different USB ports, having the HDD formatted and mounted, unmounted, etc.

Finally I gave up and connected it to the motherboard via SATA, and success:

The HDD is not spinning down on it’s own when connected to the motherboard, so maybe the USB HDD dock somehow causes/forces that? APM level is 164.

Any other test suggestions for a new HDD? Currently running badblocks -wvs -b 4096 [device] which will take 13h.