Return to Level1Techs.com

Error Code -5001 : 0x80070002 During Realtek Audio Driver Install. What can I Do?

Had to do a clean install of Windows 10 for my custom-pc. I actually did a few drivers here & there & then some updates in roughly that pattern & everything worked out fine. Except for trying to get my Realtek Audio Driver installed, that is. It seems to think I still have a program or some other setup running when I DON’T! I should mention that my motherboard is an Asus ROG Strix Z390-E Gaming & I did attempt to download/install the driver directly from the product support page. TBH, I’m not really sure why I’m getting this weird error message, but this is what it says:

An error (-5001 : 0x80070002) has occurred while running the setup.
Please make sure you have finished any previous setup & closed other applications. If the error still occurs, please contact your vendor.

Under Details it says this:
Error Code: -5001 : 0x80070002
Error Information:

setup.cpp (142)
PAPP:
PVENDOR:
PGUID:
$21.0.351
@Windows 8.1 / Server 2012 R2 Service Pack 0 (9600)
IE Version: 9.11.19041.0

I have tried contacting Asus via their phone support, but I just kept waiting & waiting for what seemed like forever! >:( I also made sure I didn’t have any audio devices connected, but that didn’t help.

So, I’m open to suggestions/advice/tips, etc if any of you have anything to offer. :slight_smile: Don’t forget to ask me anything if you need any other details or have questions. I hope someone can help.

Thanks in advance!

Realtek now has its own driver install thru windows update. Clean out the realtek drivers and allow the install thru windows update. Possible this might apply but you might give it a try ?

It actually doesn’t, but thank you for the suggestion anyway. :slight_smile: Upon a clean install of Windows, the Realtek Audio driver isn’t included hence why i have to go directly to my motherboard’s product page & download it that way. Plus, I have not seen the driver update I need via Windows Update anyway. Just not sure why I’m getting that stupid error message… :roll_eyes:

There is audio control panel that is very often slow to install.

It’s not included on install. It’s included after the like fifth round of windows updates.

This actually looks like the same error code that Windows Update throws if your system time is wonky. Bios battery seated / system time is up to date?

Yep. Windows is fully up-to-date & I have all my other drivers that I got from my motherboard model’s product page. As for the time, i haven’t noticed any issues with that. Now if I could just figure out why I’m getting that annoying error message & fix it, i’ll be good to go!

You checked the system time was up to date (both date and time?).

If so, and you’re still not having luck, then go to “Device Manager” and snap a screenshot with the “Sound, Video, and Game controllers” group expanded. If you have the “Audio inputs and outputs” group snap a screen with that group expanded as well.

After you snap that screenshot label it (before) and then go into “Add and Remove Programs” and uninstall anything related to realtek from add/remove programs.

Restart your PC. Run windows updates. Restart PC again. If you still don’t have audio available then take another set of screenshots from Device Manager with the groups mentioned above.

Also snap a screenshot of your sound control panel: control panel -> hardware and sound -> sound -> first tab - “playback”. If you’re on classic control panel view then just… control panel -> sound -> first tab - playback.

Looking at both my audio screenshot & the screenshot in Device Manager (before), you can see I don’t have anything by Realtek installed. Not even in Control Panel under Add or Remove Programs! I checked date & time, & they are perfect. I also tried what you suggested & even went as far as as cleaning my update cache, but that didn’t help. Just believe me when I say that my Realtek Audio Driver is NOT installed by default after doing a clean install of Windows 10; that’s why I have to go to my motherboard’s product page in order to get any needed drivers.

BTW, this is the order of the screenshots: BEFORE< Audio, & then AFTER in case you were wondering.

Have you tested to see if you have basic audio ? If so…wait for a day or two before moving on. the realtek audio panel can be accessed by start menu.

I do have audio when I have my headset plugged in via USB, but I would prefer to have the Realtek Audio Driver installed properly.

if the new realtek control panel is not on your start menu… just wait.

I prefer to have it done now as I’m just nitpicky. Try to understand.

I am telling you are not going to be able to until windows updates decides to install the new console. I understand. Been there done that. Realtek drivers are now gated thru windows update.

I get your point, but I never said this was console-related. This is pc-related. -_- Besides, not every pc out there will receive the same updates. Like I stated earlier, I haven’t even seen the Realtek Audio Driver offered via Windows Update for my system.

Realtek has its own console within the windows start menu. Not gaming consoles. From my experience, it often installs day or two later because whatever reasons. ?

You’re probably thinking of OEM brands like HP, Dell laptops, etc. Besides, bear in mind that I have a custom-pc as mentioned earlier.

Now it is entirely possible that there is another issue but you will not know until the realtek audio console fully installs.

Update for you: I FINALLY managed to get connected to an Asus technician via their phone support. For some weird reason, it wouldn’t let me proceed before when I extracted the zip folder. Instead, this time, i simply opened it, ran the setup, & this time it worked! :smiley: I really don’t know why it was acting that way earlier, but I’m glad to have my audio driver properly installed now. Thanks to everyone heree who tried to help! :slight_smile: