Return to Level1Techs.com

'enp3s0' Unstable (Only works with gaming keyboard plugged in)

My issue is that I have installed the latest CentOS 7, Did a netplan to set the ip static and install plex and sorts, that al worked well with my gaming keyboard. But whenever I reboot the device with my PS2 keyboard the console starts to spam these messages as seen in the picture below.

So I figured out that whenever my gaming keyboard is not present, it won’t work, even when booting and plugging it out it immediately disconnects the internet and starts spamming these console messages.

What I also tried:

  • Installing windows 10 (Internet worked fine there)
  • Using a Ubuntu 18.04 (Same issue, same console output)
  • Re-installing CentOS 7 (Same issue, same console output)
  • Lots of commands and threads on the internet, I lost count at some point.

If anyone has any idea or a suggestion of where to look for a linux beginner I would appreciate that, or anyone that had this issue.

Specs:

  • ASROCK J5005 ITX moatherbord (Realtek RTL811H networking adapter with driver r8169).
  • Corsair Builder 500 watt psu, that must be enough for a 12 watt cpu.

whenever my gaming keyboard is not present, it won’t work

Does any usb device (I am assuming your gaming keyboard is usb) keep the network driver from flipping out?

BIOS up to date?

Try running a newer kernel? You need to add the epel repo I believe to install the linux-mainline package.

#1 Any other usb device doesn’t work (Hdd that I fstab mountd), ps2 keyboard, usb stick. usb fan.

#2 my bios is up to date according to the bios online flash tool (When using my gaming keyboard)

#3
I might try this, with a new kernel, could take some time as I don’t know how to do that yet.

UPDATE:
A new bios update was available, so I flashed it (1.40 now). Didn’t fix the problem, Bought a usb keyboard that works, problem still persists with this keyboard, but it still works with my gaming keyboard, and I don’t know why.

I will try to use some other linux distro and see where that goes. Else I will just switch to windows…

The issue that you are describing is bizarre. Did you try another distro yet? Does your gaming keyboard have a USB port? is your NIC integrated into the motherboard? Is it a wireless by chance?

can you post the output of lsusb -vv?