Elden ring seamless co-op

I’m wondering if anyone knows how to get mods to work with proton. I tried Seamless Co-op for Elden Ring, but crashed to desktop.

I got dsfix for dark souls to work in the past with

WINEDLLOVERRIDES=“dinput8=n,b” %command%

seamless co-op has it’s own .exe launch_elden_ring_seamlesscoop.exe

Any idea’s on how to get it to launch in linux with proton?

steam-10457769659510816768.log.zip (15.3 KB)

Launched with Proton 7.0. Took about 15 minutes for the game mod to launch for the first time.
Still need to check if the online aspect works with connecting to another player.

Did you find out if it worked online? Also if you don’t mind me asking, how did you get it to even boot?

Can confirm seamless cop mod completely works in linux.
Add non-steam select seamless coop .exe and select start-in same path as eldenring.exe and seamless coop.exe.
Make sure to force compatibility and Proton 7.0 was the only one that worked.
Also takes about 10 minutes for the game to boot each time.
Just some classic linux/wine jank.

Test on ryzen 5800h and both a 6600 and rtx 3070.

1 Like

Thanks! I’ll give it a try tonight. Appreciate the quick response!

EDIT: Unfortunately it seems it’s having issues locating the seamless coop .dll file so I’m stuck as of now. @pmilleroly27 when you mentioned Proton 7.0, was that reffering to 7.0-2 or do I need to install another version via ProtonUp-QT? As well, you mentioned “select start-in same path”. What did you mean by this specificially? I hope you don’t mind me asking.

I get an instant boot and it doesn’t load my save files from retail, but the mod itself does not work. None of the items it gives you at the start are available, and I get a message that I was forced offline due to “Inappropriate Activity Detected”

Proton 7.0-2 is the one I used

add non-steam game


“/home/user/.steam/debian-installation/steamapps/common/ELDEN RING/Game/launch_elden_ring_seamlesscoop.exe”

start in

“/home/user/.steam/debian-installation/steamapps/common/ELDEN RING/Game/”

the .dll had an update, download below is original if you want to see if rolling back works, but I just test the new one and it works for me.

elden_ring_seamless_coop.dll.zip (122.8 KB)

again it takes 10 plus minutes each launch for the game to load in my testing and could be slower with weaker cpu’s then a 5800h.

When I launch the game a black terminal launches and stays open tell existing the game.

The black terminal endlessly spits out commands.

Performance wise the game is unplayable on 6600m, but completely playable on 6700m and rtx 3070 mobile.

6600m is slower, but shouldn’t be as slow as it’s performing

Laptop’s on linux can be a weird experience.

Thanks for the fast response! I’ll try the DLL provided and the syart-in, etc and see. If not, I checked in a couple other places and was told it works out of the box with ProtonGE 7-18 so I’ll try that as well and report back