Return to Level1Techs.com

Dual monitors in Linux

Hello guys. You saved me a couple times, and seems like I need your help again.

PC:
Kubuntu 18.04
Asus AMD R9 380 Strix
LG Ultrawide connected with DP
Samsung 5:4 connected with VGA and passive DVI-I dongle.

After successful Linux home server setup I’ve decided to go full open-source and installed Debian 9.5 with KDE on my main system alongside Windows 10, but had not very much luck with GPU drivers. After some testing with out-of-the-box 4.9 kernel and AMD driver from repository I got system that detects both my monitors, actually shows picture on both of them, but had a problem. Startup took ages. Like turn on - wait 5 minutes - here comes TTY login screen - another couple minutes - yay, KDE Plasma login screen. Enter password, wait for about 1 more minute, and here is my working dual-screen desktop.
I installed kernel 4.18.smth from backports (latest available), it fixed long startup completely. But now I have only one monitor actually working, other one is detected, OS says it’s being used, some windows open there, but in reality it-s blank with blinking in standby power LED. Same deal with proprietary drivers and open ones.
I moved to KUbuntu (I personally think default Ubuntu’s Unity desktop is ugly), same here with any kernel from 4.15 to 4.19.1 (current).
So now I am on Kubuntu (decided to stay for better third-party apps support, no distro can match Ubuntu in this, I think), kernel 4.19.1, built-in GPU drivers, only main screen is working. Googling gave me several similar topics across the internet, but none of them really helped me. Can some of you, probably?
In OS:


In reality:

I am still pretty noobish in linux, please ask for any logs, but also suggest where to find them.

And… Why did you install just straight up debian? Don’t get me wrang, you do you, I’d he just grabbed ubuntu and not needed to screw around with stupid configs and stuff.

I am on kubuntu 18.04, kernel 4.18.something, open source drivers and Vega64. I have no problem running dual screens.

I know I had less options in terms of refresh rates in some cases. Also: how are the displays connected? HDMI, DP, DVI?

I used it on server, just didn’t want to rewrite USB stick in the beginning, lol. Not like I felt it a lot more difficult in use than Ubuntu, in fact, but I stick with Kubuntu now, as I setted up a bunch of other things already.

1 Like

Sorry, forgot about that. Ulrawide uses DisplayPort, 5:4 uses VGA through DVI-I dongle. Would’ve tried 5:4 with active HDMI dongle, but my dogs ate it and made me cry a lot.
I noticed that most of the people with this issue use older GPUs, but R9 series is still listed in even AMD proprietary driver support list, and it’s built on GCN as everything later, including VEGA.

That might be the issue. Can you get a different display, maybe a used dell from ebay? Something running proper DVI or even displayport?

I don’t really want to do this, my last desperate act would be buying another HDMI-to-VGA adapter. But I want to fix this issue properly, not have a dummy port.

The open driver might not support VGA. Regardless of how old GCN or your card is, VGA is ancient. Don’t spend money on more adapters, I don’t think that is gonna fix your problem.

Active adapter transcodes digital HDMI signal into analog VGA, so it’s HDMI for system, And it’s way cheaper than used monitor, and is useful in future, when I change my GPU to something newer without native VGA support.

doesn’t make a lot of sense to me TBH. First off he said it worked previously before the kernel upgrade. Secondly the system probably doesn’t even know about the VGA since it’s through adapter. And third, I used this type of set up years ago and if worked fine (with a GTX 570 and later and R9 390) both with passive and active adapters.

Anyway, have you tried turning it of and on again downgrading the kernel again to where it was before? That’ll probably introduce the boot issue again, but if it works it might just be an issue with either kernel or amdgpu or both. Or even X11 (if it’s not Wayland already).

I found the KDE program for setting up monitors was not very good. I switched to arandr and it seemed to be more capable of setting up my four screens than any other program.

arandr is a gui for xrandr.

This is the xrandr command that arandr outputted for me just to give you and idea.

<code>xrandr --output DisplayPort-1 --mode 1366x768 --pos 5760x0 --rotate left --output DisplayPort-0 --off --output HDMI-2-1 --mode 1920x1080 --pos 0x286 --rotate normal --output DVI-D-0 --mode 1920x1080 --pos 3840x286 --rotate normal --output VGA-2-0 --mode 1920x1080 --pos 6528x286 --rotate normal --output DVI-2-0 --off --output HDMI-A-0 --primary --mode 1920x1080 --pos 1920x286 --rotate normal</code>
1 Like

Adapter in use is passive, DVI-I supports analog output. Open driver version is different in different kernel versions.
Tried downgrading Kubuntu to 4.9.smth kernel, that refused to boot. Would try debian again tomorrow on a different drive and post results.

I tried manually set monitors up through xrandr and it did not help, would try again however.

Try arandr it makes life much easier. I can do it through xrandr but arandr makes life much easier.

No progress, still blank screen.

Could it be that your adapter just died? I’ve had that happen with multiple adapters. I too use old monitors as secondary monitors. If they work, why not use them right? I’m thinking maybe with the quality of these adapters, which are usually very cheap, it may have died. Have you tried another adapter?

I had this problem before, and trying a new adapter fixed it for me.

It works in BIOS and Windows now.
And I noticed a funny thing: all this fun in Linux somehow screwed up my Windows drivers. Lol, I don’t know how it could happen, but using my discrete GPU Windows 10 just freezes during boot:


Boots fine is safe mode and using integrated GPU, now trying to reinstall AMD driver in Windows and see if I get it to boot properly. If not - guess it somehow messed my vBIOS, gladly I already have an image and tools after OC experiments.

have you tried getting an updated mesa ppa?


thats the recommended mesa drivers for using steam play.

Now I am trying to at least resurrect my Windows graphics. Now it kinda looks like Linux damaged my GPU, lol. Changing vBIOS, wiping off and reinstalling drivers in Windows doesn’t help, still starts only on iGPU, with discrete it looks like it considers both monitors as not primary or something. But they stay blank, and LEDs on peripherals tell me OS in running.

I don’t really know what to say.


Well, I am not very experienced with Linux, but I am not retarded and have a not-so-bad expirience in playing with hardware. And somehow I fried my GPU by installing Linux driver? This is looking like overheated memory for me, I am very sure it wasn’t dead yesterday and I did nothing obvious to kill it. I doubt I can still RMA this card.