Drupal - Really not important, but issue with CSS not loading, perhaps permissions?

Hello all,

Firstly, I can’t overstate it enough how unimportant this is, just a curiosity more than anything - I am not a competent or regular web dev.

So I’ve dabbled with Drupal in the (distant) past, I thought it was pretty good - though I ended up doing my ‘business’ websites just using HTML, PHP and CSS.

Fast forward to now, I installed Drupal on my shared server via a very cheap company (IONOS) and it appears not to load the CSS and receives “500 Internal Server Error” when I tried to go deeper into the directory, to look at settings, etc.

  • I installed it by downloading the drupal zip (latest)
  • extracted using 7zip and threw them on the server.
  • When the upload was done (filezilla), I went to the website and the install seemed to go smoothly, with only a minor issue, which didn’t seem to be important (below).
  • Immediately after finishing the install, I was presented with a CSS’less page.

When I deleted all files, I noticed it was difficult to delete ‘sites’, ‘sites/default’ and other structures below that. I ended up deleting them individually, no bother really, but odd.

The default permission when uploading locally to server seems to be 604, if that helps to know.

So like I say, really not that important, just a bit curious really! :+1:

check the directory permissions are 755. Try toggling aggregation on or off.

if aggregation is on it compresses your css/js and puts that compressed file in sites/default/files

so if that path is inaccessible or 500 errors it may indicate a permissions error, or a botched .htaccess directive somewhere down that path.


Wow, I’m tickled that you responded Wendell, didn’t expect that :+1:

I’ll do exactly what you say and respond with any success/fail result.

Just while I’ve got your attention, just wish to say well done with the weekly news show and podcast version. It’s become part of my routine now and I thoroughly enjoy the delivery and content - you three are a peculiar combination that seems to work really well, a bit like Top Gear used to (UK Vehicle related show). :+1: Keep up the good work.


you might be able to pull error_log from the site root and see “what” the 500 error is complaining about. But usually its permissions or something like that.

1 Like

Thank you, I’ll do that.

So far I’ve clean installed with clean db, then 755’d the directories, but still no joy. I don’t give up easy though. :+1:

OK, so a little update, it ‘could’ be to do with the FTP account login I was using, so I’m just deleting the current install, then I’ll re-install using the new details. I’ve checked and the only htaccess file will be the one that the drupal install includes.

Like I said at the beginning, this is really low priority! :slight_smile:

Here’s what I get so far.

Does the web developer tools in your browser list any files that are not loading, or any debugging info?

1 Like

I think that’s what I’ll try next, thank you for the reminder, Firefox is pretty good to use isn’t it.

I’m having to put this on hold, as I need to build my office, before I get kicked out the current one :frowning: