Dokuwiki assistance (Resolved)

I’ve been banging my head against this issue for entirely to long. I’m going to try to strip this down the relevant bits.

The error message I keep getting after trying everything I can think of is.

And this is on the installer web page.

I’m running Rocky Linux in ESXI VM. The intent is to setup Dokuwiki with nginx as the web server. Eventually I’d like to have multiple instances. I did my research and came up with the following two guides.

Nginx Guide
Dokuwiki Guide

The one specific to doku wiki uses apache. The one for nginx is generic. So I start with getting nginx up and running. Eventually realized I missed the php pre-req so I back track to an earlier snapshot of the VM and get php running.

Att this point I’ve followed the nginx guide up to creating the folder for the files, creating the user and setting permissions. I make “/usr/share/nginx/html/dokuwiki” and set that as the home directory when I make my dokuwiki user after making the group.

Now jump tracks from either guide to what I thought is what I was missing and that was setting the php user. So I set php to run as dokuwiki. I restart the services and verify php is running by dokuwiki by using the script from Dokuwiki’s page.
Dokuwiki permissions

Next I followed the Dokuwiki guide to get the files downloaded and extracted to the correct location. "/user/share/nginx/html/dokuwiki/tech-repo Head back the nginx guide update the nginx config to point to the correct folder. Restart the whole VM hit up the IP address and I’m still getting the same error message.

Follow the last few steps in setting the permissions for the folder.

sudo chown -R dokuwiki:dokuwiki /usr/share/nginx/html/dokuwiki
sudo find /usr/share/nginx/html/dokuwiki -type d -exec chmod 555 "{}" \;
sudo find /usr/share/nginx/html/dokuwiki -type f -exec chmod 444 "{}" \;

Restart the VM again and I’m still getting the same error message. I can’t seem to find what I’m missing. Any help would be appreciated. I hope I made things clear with all the mud thats swimming in my head about this.

Maybe it’s an SELInux issue?

You could check /var/log/audit.log to see if there are messages in there.

Another quick check would be to see if it’s SELinux is enforcing.


Will show you.

You can disable it temporarily by typing setenforce 0 and then try to reload your docuwiki page.

If that fixes it you know you’re dealing with an SELinux challenge. You can enable it again by rebooting your system.

Doesn’t seem to be an SELinux issue.

I ran setenforce 0 and verified with getenforce that its in permissive mode but the issue is still present.

What should i be looking for in audit.log? Theirs plenty in their. I searched for the main pid of nginx and php and was not able to locate either one in the log file.

Ok. So it wasnt wholly selinux. It really was permissions. When I made my user owner I had not actually set their permission level except with,
sudo find /usr/share/nginx/html/www -type d -exec chmod 555 "{}" \;
sudo find /usr/share/nginx/html/www -type f -exec chmod 444 "{}" \;

I adjusted those commands to be,
sudo find /usr/share/nginx/html/www -type d -exec chmod 0750 "{}" \;
sudo find /usr/share/nginx/html/www -type f -exec chmod 0750 "{}" \;

Combine that with the selinux exception made here resolves the issue. Dokuwiki installer

And I’m finally sitting at the setup page for Dokuwiki after way to much time has passed. At least I finally have a place to document these adventures so maybe I can avoid repeating some of the issues.

1 Like