Return to Level1Techs.com

Display problem with AMD and kernel 4.19.0


#1

I have this problem with my Vega 56 and kernel 4.19.0.

My Display (ASUS MG279) gets this weird distortion on the right side of the screen. This only started happening with 4.19, and only at frequencies above 60Hz (I added a picture of how it appears at 144Hz).

I am guessing this might be a bug in the 4.19.0 version of the AMD graphics stack, but I don’t even know what this distortion is called in order to find out what is causing it.


#2

I would try a different display cable first if you haven’t already.


#3

What window manager are you using?
Have you tried xrandr or arandr to adjust your screen settings?


#4

Different cable and port gives the same result.

I am using kde plasma 5.14.2. This also occurs when SDDM loads before going into KDE.
I used xrandr to adjust frequency and the same problem occured.

I am almost certain this is a bug in the latest kernel, because I can fix it just by booting into 4.18.


#5

Interesting, thanks for the update.

I’m currently waiting on parts to assemble a new ryzen machine using a vega 56. I also plan on using plasma with arco / arch (probably going to play around with i3 as well). If you find a fix please post here, if not, I’ll post in a few days and let you know if I see any of these issues as well.


#6

I don’t know of any fix, but this is nice to know. Was gonna switch to 4.19. Thanks for letting us know.


#7

I have an Nvidia GPU rather than an AMD. When I tried 4.19 on my PC the display fell back to software rendering mode. Had to roll back to 4.18.16


#8

I have the Exact same screen with the Exact same problem.

I’m running fluxbox on Arch Linux. Tried messing about with Xrandr, Tried updating the entire GFX stack to git versions and it didn’t do anything. Only running the monitor at 60hz worked, and even then display performance was awful.

I have no idea on how to troubleshoot this issue as there was no issues in dmesg, journal or Xorg log. So I rolled back to 4.18, works fine.


#9

This issue has been fixed as of 4.19.4


#10

I had some artefacts/horizontal lines when tried to set over 60Hz on my 75Hz monitor and RX480. For me changing resolution to lower one (1080 to 720) and back to normal fixed the issue. I’ve set the script to do it every time I log in. Maybe that will help in your case too?