Diablo 2 Resurrected in WINE with Gamepad Issue


I have recently switch from Windows to Manjaro KDE and have managed to successfully install D2R through Lutris and game appears to be running fine with out issue.

However I have noticed that while D2R picks up my xbox one wireless controller without issue and mostly works I have noticed the ingame courser at inventory screens does not move but it does appear the controlls are working. (Xbox controller support is done via xone)

I have managed to replicate this issue in wondows when you goto use something like ParSec or Sunshine streaming with a game pad. In those instances I was able to work around the issue by launching the game through Steam as D2R would correctly pick Steam Input.

Tried doing the same workaround in linux however no luck as it appears steam linux works a little differently. Not even sure that the linux issue is entirely the same but was just trying a workaround that worked in windows for a similar issue.

Anyone else managed to get D2R with Gamepad working properly or has some suggestions I could try.