Dell T110-II server refuses to boot with Delock PCIe SATA controller installed

Hi all!

I use a Dell T110-II as a home server and could use some help troubleshooting a hardware issue.

From the beginning I’ve had it expanded with a cheap 2-port SATA-controller I got off my local Craigslist. This one to be precise. I think it uses the firmware of a HighPoint Rocket 620, since it’s pre-boot prompt identifies it as such.

Yesterday I went and got a Delock 90498 5-port controller to replace it and add some more ports. With it installed, the system shows this prompt on startup:

before getting to the following screen:

The system freezes right after the progress bar fills up and one of the options is chosen. The 2-light on the front panel lights up, indicating a “possible expansion card failure” according to the manual (page 17).

Now, if i physically disconnect all drives from the onboard PERC S100, the system DOES boot and i can see the drives connected to the Delock in the OS (I get the same result if i leave the drives connected to the PERC, but disable it in the UEFI). However, if I F11 into the boot manager, i can’t see those same drives connected to the Delock as an option.

This makes me think the Delock and PERC are conflicting somehow.

If i put the Delock in another system, it still says it detects no drives on it’s pre-boot prompt, but i CAN select a drive connected to it in the boot selection screen. The firmware feels flakey though. While it says “press any key to continue…”, pressing any key doen’t close the prompt and it stays there for the same 5-ish seconds it always does. If i set the OpROM execution policy to dissabled, it skips the prompt AND takes less time to load the boot option selection screen. I’d love to try this in the Dell, but it has no option to ignore OpROM.

This makes me think the Delock is just NFG.

I’ve also tried, but without effect:

  • All 4 PCIe slots.
  • Setting the boot mode to BIOS (legacy).
  • Changing the IRQ number of the Delock controller in the UEFI

So, does anyone think this is fixable? Is there a way I can use both the onboard PERC S100 and Delock 90498 together? Or should i cut my losses, send the thing back and get a waaaay more expensive PERC H200 add-in card?

Nonetheless, i’d love to know what failure-mode is being induced here.