Dell Optiplex 3060 Micro and m.2 10Gbit adapter not detecting

Building some homelab gear and decided to try out an M.2 B-key 10Gbit network adapter with a Dell Optiplex 3060 micro 1 liter form factor mini pc with an I5 8500T CPU and an m.2 adapter from Aliexpress:

The network adapter does not get detected by the system and is not visible on Linux with lspci and lshw and neither in windows with hwinfo.

The adapter gets worm to the touch so it is getting power. It is installed in the only full sized M.2 slot that detects SSD drives so it is functional.

Things I have tried

The adapter is detected in a Dell 3050 based on the 7500T i5 CPU and an older 6-gen HP mini PC.

Any ideas if it is possible to get it working through some workaround. Googling around I found some post of a pcie riser card + Intel 4 port gigabit nic being installed into a similar 3060 system so the slot should theoretically be universally available for PCI devices other than storage.

Is it possible that the 3060’s M.2 slot is SATA only?

Bios update also come to mind.

edit: is that m.2 slot shared with anything else / how many pcie lanes are available to the slot vs what is needed for the nic adapter!

Tried a 2.5gbit m.2 b-key network adapter in the slot with the same results so The dell Optiplex 3060 Micro is a no go in terms of this kind of expandability.

The 3050 works fine with both adaters and there are no issues in getting them detected.

PS. Tried with several different bios versions

Ended up getting a 2.5Gbit adapter that fits in the WLAN slot that is A+E key and has 2 lanes of pcie hooked up to it. Getting full 2.5Gbit speeds out of the slot and this is an option for anyone that stumbles onto this post.

1 Like