Delayed response - display and cursor

Not sure if this is a hardware or OS kernel problem:
System info:
Operating System Manjaro Linux
Cinnamon Version 4.4.8
Linux Kernel 5.6.10-3-MANJARO
Processor AMD Ryzen 7 2700 Eight-Core Processor x 8
Memory 15.6 GiB
Hard Drives 3619.1 GB
Graphics Card Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580X 8GB]
Asus VG248 monitor, Variety of mice, Azio keyboard

Across several different versions of Linux, different USB ports, 2 separate graphics cards, different mice and keyboards, a short 1 - 2 second delay starts happening to keyboard and mouse input. It sticks occasionally at first, but gradually gets to delay on every input. Eventually I will have to reboot, which does seem to fix it for a while.

As per suggestion at LQorg, I added this file to etc/X11/xorg.conf.d/20-amdgpu.conf:
Section “Device”
Identifier “AMD”
Driver “amdgpu”
Option “DRI” “2”

But it hasn’t solved the issue. Any thoughts out there?

If you use a keyboard shortcut to pause/unpause music, is that delayed? If so, it’s probably an input- or USB-related issue, rather than a graphics issue. You mention trying two GPUs. Were they both AMD cards?

Is this a new system? Has it always had this problem, or did it develop recently?

Do you have a PS/2 port to test with? That would cut USB out of the picture.

If you switch to a tty that isn’t running X, does the problem persist?

Is there anything interesting in dmesg?

Instead of restarting to fix the problem, what happens if you log out, then log back in?

Could it be a similar issue to this?

Thank you, Zibob. Sounds like the same issue to me.

I’ve disabled hardware acceleration in the browsers i use - I’ll get back with results.

He’s right saying this, in months this is the closest I’ve found.:

Due to the generic nature of the keywords involved in this topic it’s proven quite a challenge to find discussions around it…

I’ve also gone to, as referenced in Burns’ posts, and in the test I get some flashes of red and cyan, which it says is not a good thing. Unfortunately, the technical discussion is now beyond me and I am clueless as to what to do about my apparent vsync issue.

Have solved issue.
Installed the Linux kernel for AMD, and several other AMD specific things I found in the Arch/Manjaro repos.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.