Debian 8 - installing proprietary Nvidia drivers

Hey guys,

For some time I've tried to install nvidia drivers on my laptop and I've never got it working. The issue comes with that fact its an Optimus laptop (intel integrated + nvidia discrete) from my understanding

I've tired this and while it did install and it didn't just boot to a black screen like other methods have, running optirun glxgears yields no FPS increase and in games as well it did not work either. Perhaps I'm not doing it right, so if you guys could please help me or get me going in the right direction I'd appreciate it

I have an MSI GP60 which has the following hardware

NVIDIA GeForce GT 840M 2GB
Intel Core i5 4200M (2.50GHz)

If you need any further information just ask

Couple questions, which games? Are you playing any games that require nvidia graphics drivers?

Are you able to launch the nvidia control panel?

Are you sure the game is using your nvidia card and not your CPU video card?

Couple questions, which games? Are you playing any games that require nvidia graphics drivers?

The game I tried was CS:GO, so thats not a game that requires an Nvidia GPU as far as I'm aware

Are you able to launch the nvidia control panel?

It never installed, I've the last couple times I tried this I haven't had an nvidia control panel

Are you sure the game is using your nvidia card and not your CPU video card?

I tried launching it using primusrun %COMMAND% in the launch options as this Valve how-to specifies, but as if it was actually working or using the card I don't feel it was

Well for starters, you do NOT need nvidia drivers for CS:GO

IDK if you can or would even like to do this, but here is what I would do.

1: If you have not already done so, install grub2 and make sure you have updated it.

2: Download the latest linux driver directly from nvidia and save it to your home folder.

3: Restart your computer and log directly into a terminal. CD into your home folder and run the driver package.

it should be some really long name. Like Nvidia blah blah

You will know it when you see it.

This is a very direct way of installing the driver. If it spits out an error, it will tell you exactly what is wrong.

1 Like

Bumblebee allows support for NVIDIA Optimus enabled systems however does not install the proprietary driver itself. To install the proprietary driver on Debian, please do the following:

  • Install build-essential and kernel headers:

$ sudo apt-get install build-essential linux-headers-$(uname -r)

  • Disable nouvaeu:
    Create a new file in /etc/modprobe.d/ with the name disable-noveau.conf, and append the following text

blacklist nouveau
options nouveau modeset=0

  • Download the proprietary driver from here, save it in $HOME
  • Reboot your system into single user mode, or alternatively you can select "Recovery mode" in grub.
  • Remove the following packages if installed:

apt-get --purge remove nvidia-kernel-common nvidia-kernel-dkms nvidia-smi xserver-xorg-video-nouveau nvidia-glx

  • Search for all the nvidia packages and purge them:

dpkg --list | grep -i --color nvidia

  • Stop any graphical environment
  • Install the proprietary driver:

sh /home/your_username/

Replace the variables according to your system setup (such as your username, architecture, driver version, etc.), execute the command and follow the on-screen instructions. After that, reboot your system and you should've successfully installed the NVIDIA proprietary driver.

1 Like

Wow thank you guys, I greatly appreciate the detailed instructions. I'll try this soon and report back with my findings

Update: I tried your method @Mazen and I didn't have any luck

I followed your instructions and the nvidia installation went good and completed without error, and then I rebooted afterward and upon where normally a login screen would be there was a white screen saying something such as 'oops there was an error we cannot recover from' or similar.

I tried the newer 349 drivers for this, and again this is with a GTX 840M

Could you go into single-user mode again and provide us with the X11 logs?

EDIT: FYI the proprietary driver version recommended for your card is 346.72 as of this post, this may or may not be related to the issue

I'm going to piggy back this topic as it is sort of relevant to my problem.

I had just installed Debian 8 onto my laptop (Lenovo Ideapad Y500). Install worked well, booted up and installed some software including Steam and the Nvidia drivers. I also installed the nvidia-config and ran it. Everything seems to have gone smoothly without any issues.

Except now the system doesn't boot. It will go through grub, show some echo lines in the corner and the laptop will actually shut off. Maybe a kernel panic? Anyone have an idea as to what could be wrong? I can boot into the recovery and get a root terminal using the option in Grub.

I really hope I don't have to go back to Ubuntu, Debian seemed so stable until this happened.

Try booting in grub with the "nomodset" option ...if it is a video driver problem it should boot after which
you could try other drivers.

Thanks for the suggestion, unfortunately it didn't work. The laptop would show a blank screen and the fans on my GPUs would ramp up. It didn't shut down like it did before though.

I probably should have mentioned that I am running two GT 650Ms in SLI