Dead GTX 970

I have a GTX 970 that, whatever machine I plug it into, doesn’t allow that machine to boot. I’m fairly savvy when it comes to solder, but smd’s and parts like this kinda scare me. This was sort of a donor (I replaced the card for a buddy of mine), so it’s not like I’d be destroying something valuable if I boof it. But where do I even start?

Obviously I need to diagnose the problem before I can fix it. Where do I begin?

This is kind of bottom of my to-do list, so I’ll keep an eye on this thread for suggestions and post updates as soon as I can. I know from past experience that these forums are filled with people far, far smarter than myself.

Take off the cooler and do a visual inspection, then maybe multi meter what you cant to see if anything is obviously dead.


So I did that, way easier to take that apart than I thought it’d be. I didn’t notice anything glaringly obvious. One thing that I did notice, however, is a small black spot on the cooling block. It sits right where the processor is, but I didn’t see any corresponding marks on the GPU itself. I’ve been unable to wipe it off with alcohol, so it’s a bit concerning.

1 Like

Can you put a different gpu in first slot, put monitor on it, then have the 970 in the second slot and still get to bios?

You might need to reflash the vbios

If it’s a dual bios card try flipping the switch

So I thought I’d try that real quick, just because it sounds like a nice and easier solution. Unfortunately, my PSU doesn’t have enough power for two graphics cards. This one is 2x6pin, my GTX 960 is 1x8pin. I thought I’d just plug it in by itself since I was in there already. It’s such bizarre behavior. Not even a power blink. It’s like the power button is disconnected when this 970 is plugged in.

Got a molex to 6 pin floating around?

Not an extra one. I have an EVGA 600 B PSU for context

So I continued my inspection, this time with a magnifying glass. I noticed some tiny bits of solder where the should not be any (on text). I also whipped out my multimeter and found several caps that registered OL. I thought it was me doing things wrong, so I tested a known good cap. I’m not as think as I stupid I am. So it looks like I have some blown caps and I’d be willing to bet I have some shorted resistors as well. Since I don’t have the schematics of this board, I’m not really sure how to proceed. I might just try to eBay it as a broken device. Unless anyone has suggestions.

Can you post high-resolution pictures of the GPU? That way the more electrical-engineering-savy people can point you into the right area to probe. Checking fuses, VRM stages, etc.

That’s not a problem, as that’s what capacitors are; effectively open-circuit components. Testing the caps in resistance mode, generally you’ll see the “resistance” increase for the capacitor (because of your multimeter charging the capacitor), but not always.

Edit: Please also ensure that the mosfet + IC’s model numbers are readable, so that we can more accurately tell you places to probe.


I didn’t see any fuses, but I’m not totally surprised as I’ve come across quite a few GPU’s without any; they may instead be using fusable resistors (low-resistance resistors), but nothing obvious to me.

In this image, these appear to be the 2x current shunts, one for each 6-pin power connector which are nearby; ensure that they both show as a “short circuit” (nearly zero resistance) with your multimeter, by using the continuity/resistance mode. Place your multimeter probes on each side of the resistor, as indicated with the stars.

If they’re zero ohms, they’re good.

Feel free to also test this current shunt resistor in the same manner.

To backtrack, I assume you tested this GPU in multiple systems, different PCIe slots, via the different display outputs, and with different display cables? Just want to make sure before you dig deep into a component which isn’t faulty.

In this image, is the circled area corroded (ex. from liquid), or is it just flux? Can’t tell.

This is the back of the PCB, with a output capacitor likely powering something like VCore. With your multimeter, probe the green-stars with the GPU plugged in + powered on; it should be somewhere between 1-2V, but possibly as low as 0.5v. The blue stars are technically the capacitor, but I assume that the green stars (where a SMD capacitor can be placed) are in parralel with the blue stars.

If nothing here yields results, I’ll probably need you to post images of the power phase IC’s, as I can’t make out their model numbers. When I can just barely make out is the model for some of the mosfets (but not all), which are the 4C05N and the 4C10N

Lastly, for your reference, this is a VERY basic diagram of how the 12v input into the GPU is convertered to the 0.5-2v used by the GPU.

The mosfet is a “switch” that can be very rapidly turned on and off (in the mhz range for most GPU’s); varying the amount of time it’s left on vs off is how the output voltage is controlled. The capacitor “smooths” out the signal produced by the mosfet, to produce a nice and clean voltage, generally ranging from 0.5-2v for most GPU’s. Above, I am asking you to probe the output of one of these “buck/step-down” converters; if there is no voltage at that capacitor, that means there’s (likely) a problem somewhere before the capacitor. Could be a blown mosfet, it could be that the phase controller (the thing telling the mosfet when to turn on and off) is not working, or not being instructed to turn on.

GPU’s are quite simple, with a majority of the parts comprising of power delivery to the VRAM and various parts of the GPU die. Testing those power rails is a very important step in diagnosing a faulty GPU.

Both of these resistors are 0.1 ohm.

This resistor was OL

Dust bunny. I wiped it away easily.

I tried with several machines. With the GPU present and either plugged into the PSU or not, the computer will not POST. The fans on the machine tweak and then nothing. Swapped RAM, PSU, mobo, etc. It isn’t the machine, it’s the GPU. With my 960, all is good. When the machine has onboard video and no this-970, all good.

Unable to do this without jerry-rigging something, which seems kinda dangerous. I was thinking I would plug the GPU into a PSU with no mobo and just short the green wire to black on the 24-pin molex. I don’t think this is a great idea. But it’s the only way I can think of the run power through the GPU.

I’ll take close ups of the chip model numbers.

Hmmmmmmm, that’s weird. Care to double-check?

This leads me more to believe that there may be a short to ground somewhere, which may be tripped OCP (just a guess and a possibility, but isn’t always the case). If this were the case, it could easily be tested by doing exactly as you suggested;

Next step, I’d personally do this. If the PSU instantly shuts off, that indicates a direct short to ground. If the PSU doesn’t automatically shut off, then it may indicate there’s a problem somewhere with the GPU communicating with the PC and indicating a fault (my guess? not too familiar on this part).

If OCP isn’t triggered, I’d shutoff the PSU to prevent further damage to the GPU, in case it starts to draw power and heat up without a cooler on.

With this information (OCP being triggered or not), it leads to two different ways to test the GPU.

OCP triggered: Applying 0.5V to 6-pin molex input, and slowly ramping up the voltage. Using 99% rubbing alcohol (or preferably a thermal camera), see what components get hot. The GPU may get hot, but not neccesarily.

OCP not triggered: I’m not as familiar with this process, so I’m shooting in the dark here; checking GPU power rails. I’m not 100% sure on this, but I assume that even if there is no communication between the motherboard and GPU, the main voltage rails for the GPU will still be created.

Double-checked, it was 0.1 ohm as the others.

PSU Shut off instantly.

Proceeding with “Apply 0.5V to the molex connector and slowly ramping the voltage” will require equipment which I don’t (but should, given my line of work) have. Also don’t have a thermal camera, but I see the line of thinking here…

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.