Ddrescue Mac HFS+ Drive now issues

My friends Mac Hard Drive is failing, we just ran ddrescue on it. And it finished.
But the hard drive is only readable by the pc that restored it. Any other computers show the drive as blank or unknown format.

Mac was running El Capatian

We are thinking the only way to get the data is the make a network share and copy it over. But we have over 1.5TB that need transfer. And the PC we used to restore is only 10/100. So it would take a long time.

Mac boots up and has Hard Drive read errors. Then it won't boot at all. So that lead us to try disk recovery. I mentioned ddrescue to my friend. So my friend removed the 2TB segate from the mac. Then he bought a 3TB Toshiba and installed it in a desktop PC running Mint Linux 17.3.
It was able to see 3 partitions (Main: 1TB, Stuff 500GB, Work 500GB).
We ran ddrecsue from drive to drive

sudo ddrescue -d -r1 --force /dev/sdb /dev/sdc rescue.log

After 4hrs it had transferred the 2TB, but then it was stuck for 19+hrs trying to "Splitting Failed Blocks"
So we ctrl+c it, and tried it with the -n command (to ignore errors) and it told us finished. So we tried to put the drive into the mac so we could copy the files onto his new 3TB that he also bought for it. And the mac won't read the drive. But the PC we used to do the ddrescue on shows it all. We even tried another PC using Mint Linux and it has the same issues reading that drive.

On the Pc we could see all 3 partitions but the last one (work) would not mount. But we could still see all the files on the other partitions.

[I'm sorry for any spelling errors]

1 Like

iMac hd shows errors, wont boot but, sttll spins and i can get limited access to some file.

I removed the SKETCHY HD (SEAGATE 2TB_ 3.5 2012 model.
Slapped it in my HP tower, with a NEW HD Toshiba 3TB 3.5 Drive.

booted the Tower into LINUX Mint,

ran ddrescue commands. with retry set to -r1
we did the HD to HD method , not the image file.
FYI its a HFS+ formatted drive with 3 Partitions
Part 1 HD (1000gb)
Part 2 STUFF (500gb)
Part 3 WORK (500gb)

4 hours or so it reached a state of getting the 2TB recovered

but was stuck for 19 hours doing that SPLITTING FAILED BLOCKS
we re ran ddrescue with skip errors it resumes and finished instantly.

rebooted and i see the 3 partitions and files.

here is ODD part

I put that NEW DRIVE with all recovered DATA (3TB TOSHIBA) drive in my iMac. running my OS X
It simply said it cant read the drive, etc, wanted to INITIALIZE i said no of course. It sees the DRIVE but no partitions or anything.

I put the drive on my other iMac with Live Booting to Linux Mint , then again, even Linux Mint Sees the drive, BUT No Partitions show and no files.

I put the drive in a USB enclosure and tried on a Laptop with Linix Mint
NO Recognition, just sees Drive, no partitions.

Put the Drive back in the Tower i recovered the data with.
All is good, It sees the 3 Partitions and all files.

im stumped cause i need these files on my iMac. or atleast accessible?
It can be an external HD if needed, but crazy how its all strange.

Back in my Tower. i install a Brand New empty 3TB Seagate
and attempt to Copy the newly recovered files on the 3TB TOSHIBA to the NEW 3TB SEAGATE , left it NTFS formatted for ease.

thing is, is copying slow . i used

cp command and calculated 36 hours to finish and thats just the 1000GB Partition 1 Files

I need to either fix the issue with the recovered DRIVE not showing up on ANY other system , or copy all the RECOVERED FILES off the TOSHIBA to the NEW 3TB SEAGATE as best as possible.

I hope it makes sense.

I can probably help a bit with the speed issues. Are you using a USB hard drive or is it sata for the second 3tb drive? If you're using a usb drive, make sure you've got it plugged into a USB 3.0 port, otherwise you'll be getting horrid speeds.

The 36 hours calculated comes out to be about 7mb/sec assuming your drive is full. If that's the case, you're probably spot on if it's your system drive. Linux and OSX have one thing in common: lots of files. It's easier for a computer to copy a single file than it is to copy a lot of small files. Creating files has overhead on the filesystem level that prevents the disk from reaching a high mbps transfer speed because it has to write to the journal as well as the location the file is being saved to. This creates a lot of seeking, which kills performance.

A good tool to handle the file copy is rsync which is available on both linux and mac. Rsync will only copy the files needed to make the source and target directories identical, so if the copy gets interrupted in any way, it will pick up where it left off.

Secondly, NTFS is inefficient. You're probably best off installing the new 3tb drive in your imac, initializing and formatting it, then putting the drive back in the linux PC to do the rsync.

1 Like

Lets call my FAILING Drive S2F (Seagate 2TB) iMac HFS+ (3 Partitions
Lets call the DATA Drive T3 (Toshiba 3TB) has my recovered Data iMac HFS+ (cloned as Drive S2F)
Lets call my BLANK Drive S3 (Seagate 3TB) ready to accept files NTFS as from factory
Lets call my PC Bench Tower System drive B (Boot drive)

at this point

I envision hooking Drive T3 and S3 into SATA 2 connectors in the TOWER Bench system
I boot from drive B , into Linux Mint 17.3 Cinnamin.

This system is seeming to be thje ONLY system that will mount and use the T3 Drive.
No other sysems i install it in, read it (ODD) they do see it, but dont see the 3 partitions , just the drive, and cant mount or whatnot.

so lucky i can still access my Data as long as Drive T3 is in my Bench Tower system. (ODD)

all my requrement is , I need to be able to Read/Write to the Drive S3 afer done.
Access with my MAC / Linux / win macnines.

S3 Drive is current factory formatted NTFS but can be anything you suggest.....
, what options , so my mac and linux and windows macnines can read/write perhaps fat32??? or is there a better?

so im booted up using my Bench Tower PC (Linux Mint)
mount all 3 partitions of the recovered Drive T3
Drive S3 is empty and ready for prep and files.
i am ready to copy now.. best way... from Folder on T3 to FOLDER on S3

PS... and i tried rsync and cp and mixed results , but im not proficient , NEW to linux.
i used cp and it was so slow just clpying a 960 GB folder from partition 1 from Drive T3 to Drive S3 was gonna take 36 hours,

i haulted and am now seeking better method.

side note....

FAILING Drive S2F is a Seagate 2TB made in june 2012,
Pulled from my iMac, after issues booting.
It is HFS+ Formatted and 3 Partitions
Partition 1 called HDSYSTEM (1000GB) near full
Partition 2 called STUFF (500GB) Near full
Partition 3 called WORK (500GB) only 192GB used
The Work Partition is seeming where most of the issues are and seems unable to MOUNT at all.
But will run more attempts later, focus on the oher 2 partions that seem 100% recovered

As far as the best way to do this goes, I would recommend taking S3 and formatting it to HFS+

HFS+ uses different file permissions types than NTFS, and you can lose file permission data if you copy data from HFS+ to NTFS.

You have HFS+ support because you can mount the partitions, so that's good. To make a new HFS filesystem, you can use GParted.

To do this, open GParted, select your drive, right click the partiton, format to -> HFS+, click apply and wait for the format to complete.

Now that the format is complete, mount all the partitions you want. I'll assume drive S3 is mounted at /mnt/S3 and the 3 partitions from T3 are mounted in /mnt/T3/ with subdirectories hdsystem, stuff, and work.

so your drive mounts would look like this:

/dev/sdc1       /mnt/S3
/dev/sdb1       /mnt/T3/hdsystem
/dev/sdb2       /mnt/T3/stuff
/dev/sdb3       /mnt/T3/work

From here, we're ready to rsync the data. I'll share my recommended command flags for rsync. Man pages can be some very dry reading.

rsync -av --progress /mnt/T3/{hdsystem,stuff,work} /mnt/S3/

A little explanation of what the command line arguments mean, taken from the man page:

-a, --archive               archive mode; equals -rlptgoD (no -H,-A,-X)
-l, --links                 copy symlinks as symlinks
-r, --recursive             recurse into directories
-p, --perms                 preserve permissions
-t, --times                 preserve modification times
-g, --group                 preserve group
-o, --owner                 preserve owner (super-user only)
-D                          same as --devices --specials
    --devices               preserve device files (super-user only)
    --specials              preserve special files
-v, --verbose               increase verbosity

So essentially, you're making an exact copy of the files to the other disk, with permissions and time stamps in tact.

This will take a long time, but no one ever said data recovery is fast.

Depending on the sizes of the files, it will slow down and speed up when it's copying different directories.

This is the best method I can think of. I would really just let it run and see what happens. The computer has to do a lot of work to transfer this data, so it's not surprising it's going to take a while.


Had to make another ACCT. i am DavidVoy and Deee2theVeee. Using VPN ,
I just tried to REPLY and my god i couldnt,
cause they said i had to wait 24 hours to post more .
Nope,........ I am posting NOW.


I wont be using this site much more if the process is so frustrating.

I lost my paragraph reply too, now i have to re think and re type.

This sucks.

could you PLEASE continue our discussion elsewhere, so as to not have so many issues tryimhg to use a FORUM.

I been using forums for near 15+ years! NEVER experienced such a Frustrating FORUM as this site.
this is the WORST FORUM Experience EVER for me,


feel free to email me direct david voy at gmail dot com

I'm not sure what's going on here. I've never had an issue of this sort with the forum. Have you tried contacting the administration? @wendell may have some input on this.

Have you tried clearing your browser cookies or re-logging?

I don't give out my email for general forum business, so the only way I'll be able to help is either on IRC or the forums. They're a great resource and I hope we can get you up and running again.

I got this when trying to reply to @Wendell
We're sorry, but new users are temporarily limited to 3 replies in the same topic.

You've reached the maximum number of replies a new user can create on their first day. Please wait 20 hours before trying again.

I got this when trying to REPLY here in this Thread as my DavidVoy Acct,

How INSANE. the limits and delays, WORST FORUM EVER for me.
May never return

what IRC Server and Channel :) Ill be glad to meet you on IRC, i am thinkubg of NAS 4 FREE as my option to fix my issue too.

I'm currently on EFnet, #teklinux. I'll be on for the next couple hours, but it's getting late for me. Feel free to join me.

NAS 4 FREE may be a good option if you need to share the data over the network, I'm familiar with FreeNAS, so I'm not sure how much help I can be with your choice, but I'll do my best.

Also, I'm sorry about the awful experience with the forum. I'm sure there's a good reason for the new user post limitations.

I guess the RULES are to keep out spam??? So you are told , wait 20 hours to post again.
How effective was that ? Anyone who really wants/needs to post CAN, so all they did was piss off a new legit user in me. and im surely not expecting on supporting this site long. its the dumbest and most frustrating FORUM i ever used.

a 3rd Ridiculousness was , Troy was at my house, created this thread.
Then I , signed up, and added my exttra info.

We were flagged as SPAM and i literally had like 3 or 4 admins asking why we have same IP , but diff users and names and acct. and same IP

DUH!!!!!!! i explained he was at my house. They seemed to expect it not to happen, ODD.

this site SUCKS

If you're that upset about it, you don't have to post or participate.

If not, I'm on EFnet right now, we can work through the data recovery stuff if you'd like.

i know im just explaining . ok ill jump on EfNet now :)

I'm sorry for the issues you've had trying to use the forums, I believe only @Alamar and I contacted you about the duplicate accounts.

For the forums, the measures are indeed to prevent spam. You got flagged because two accounts from the same IP were replying to each other in a post one of the accounts made, which more often than not is a bot or person with multiple accounts. We can't tell if it's two different users without investigating.

Its a mimor inconveniamce, a lot of forums have similar limits, we can bump your account to lift the restrictions if required, all you needed to do was ask about the issue with posting. Let me know which account your like to keep posting with.

In the mean time IRC is a good resource as mentioned for quick fire troubleshooting lots of good people there myself included usualy when I'm not working.