DDR2 memory compatibility issue on Asrock G31M-S

I'm working on a client's computer that wanted to upgrade the RAM memory up to whatever degree of capacity the motherboard is compatible with, so I went on and bought a couple of Kingston KTH-XW4400C6/4G, which are DDR2 800MHz 4GB each. I turned the computer on as soon as I installed them, and got no signal comming from the display. I tried each module independently and got the same result, so I installed the original memory and it passed the POST without any problems.I suspect that the memory modules are not compatible with the motherboard/CPU somehow, thou there is no indications the modules are not compatible.
I am wondering whether this is a malfuction of the memory modules or if there are some pins or BIOS configuration I should be modifying to make them work.

Has anyone any ideas?

Reset the CMOS?

First thing to try and see if you can get a BIOS update for the board.
Make sure it is this board:


You can find the BIOS updates here, some of which may fix memory compatibility issues

There is an R2 version of it too.

Aside from that it is worth mentioning that the G31M platform had it's fair share of memory fails. Have you tested a mix of the 1 old ram stick in slot 1 and new stick in slot 2.

See if it will post then?

Also maybe post what the prior RAM is. Could be a case of dual rank vs single rank ram support.

For looking at the ram configuration I can recommend this tool (just use the shareware version)


It also features an extensive RAM database to lookup specs and differences between ram modules.

32 bit os?



Yes, CMOS has been already reset.

I have already updated the BIOS to the newest version posted in the same web page. What is an R2 version?

I didn't try a mix con old+new modules. I'll try that and post the results here.

In my experience DDR2 is flaky as hell once you cross the 4GB threshold. Although many chipsets of the era claim to be able to run 16GB, I have only seen a very small handful of people that were actually able to make it work.

I had an LGA775 Nvidia 780i board I was able to get 8GB working on, but only clocked at 800MHz, bumped voltage to the memory controller, and overclocked FSB. I could not get it stable at anything close to a default configuration. You may have better luck with your chipset, however.

I don't have much experience in overclocking. Could you please tell me what should the FSB be overclocked to in order to make these memories work? Or at least tell me what should I be looking at?

This was just in my particular case. It has been a few years since I played with DDR2.

If you get it to post, but it is still unstable, I would try bumping the voltage to the memory controller or underclocking the memory, if needed, to get it stable.

@FaunCB, do you have any experience with this hardware?

EDIT, https://linustechtips.com/main/topic/232325-lga775-core2duo-core2quad-overclocking-guide/

LGA775 Overclocking guide.

Nope I work on oem stuff and hacking hardware. I've only recently (2015) got simethi g newer than a pentium 4 desktop.

Thanks for the link!
I'll read throught the post and see if I can get a positive result.
Unfortunately the system is not being able to post at all.

Hmm. I was running 32Gb and even 64Gb setups of DDR2 at 1066MHz not too far back.
Granted they weren't your average consumer boards.

But it was totally possible. 8Gb should be a breeze too, I had 8Gb on a 4 slot P5NE-SLi board in 2007?

That said, the G31 platform was/is also capable of accepting 8Gb in 2 slots.

Not consumer hardware; I'm sure that has something to do with it. 8gb DDR2 films are almost unheard of in the consumer market. Not saying they aren't out there, but they are far from the norm.

I am suspecting these modules come from an HP pre-biult computer, so they might be compatible with HP motherboards only. This is just a thought, but it is the only thing that I can think of up to this moment.

Have you started testing the hardware? If not, are the components known to work? You may have another piece of hardware causing the fail to post.