Date time and locales out of whack

Hello world,

I noticed since started to use Linux that the calendars and times on websites are all off by 1 day. I have synced my timectl to the HWclock so it should be properly in sync, but this still keeps happening. I have the time set to the timezone I live in, the hours are set in 24 and the formatting is English-GB. How come this happen and I never had this on my Windows machines?

I took this picture on Monday 5th of September.
Screenshot from 2022-09-05 15-57-20

Is the BIOS time set to local or UTC 0? try to switch it.

This and what is your locale set to? Manually changing this wont fix the issue if you are not set to a Standard time in the BIOS and your locale offset is wrong.

For some reason the BIOS was set to UTC ye, changed that and then set the time correctly in the system. Have restarted few times since but still the issue persists.
Screenshot from 2022-09-07 15-46-26
I know it is the same website but I’ve gotten this on many websites for example certain successfactors don’t even work because the date input just ends up being invalid for some reason.

Screenshot from 2022-09-07 15-50-18

Screenshot from 2022-09-07 15-50-55

From what I see:
UTC is 13:50:06
But you said

It is recommended to leave the system clock (BIOS) in UTC.
You local time is a +2 HR offset.
The system clock is not syncing, you are not using an NTP service, and your RTC is not in local time… but your statement above conflicts with that.

Back to your locale… what is the output of locale?
Based off your account information it looks like our locale is set to en_GB So between using Rome CEST and an incorrect UTC and a locale that probably is assuming GB time, that may be your issue there.

Example I use a JP/EN locale mix but my TZ is Pacific Standard Time and my RTC is set in UTC. I have been running these setups for ages with no time calculation issue.

1 Like

Output of ’ locale ’
Screenshot from 2022-09-08 15-18-26

I’ve always had my BIOS synced to my local time, altough now it was set to UTC. Rome is the local time.

Now looking at the above output it could be that en_HK is the issue, I don’t know how. Are webpages probing my PC language…?

Yes. Unless you are overriding in your browser, the browser is just passing this information along. This is why locale is important if you are going to run application defaults as they will just defer to what the system has set.

I don’t think it is an issue with time but it could be causing some other issues for you. Specifically your time is set to fi_HI_UTF-8 so Finnish?

I don’t mean to sound like a typical US American but how many languages do you speak? More importantly, you may want to at least set your LC_TIME to match what you have in timedatectl. Do understand that the LC_TIME only effects how time and dates are displayed but there could be some other mechanisms looking at that and timedatectl and getting confused.; clever developers will be clever.

Outside of that, I cannot say why you are having your issue but I would recommend leaving your RTC in UTC and then do the sane offsets like most normal users. Zulu time is the best time. Everything else can be more easily computed since Z time does not observe daylight saving time.

For the website part wouldn’t I be able to change these in Firefox
Screenshot from 2022-09-08 18-16-56

Clearing things up here a bit:
Keyboard: Nordic (SV FI) layout
Local Time: Nexus Romanum (Rome UTC+2)
Lang: Should be English (just because I choose some other than US because of proper English grammar correction e.g. initialization instead of initialisation)
Measurements: Metric
Monetary: Euro
Calendar: Holocene
First day: Sunday

I should probably just create my own locale file? and on your question, let’s say English is not my second/third language.

edit: regarding the above locale in browser I made some changes:


You may benefit from a custom locale. It should making moving into a new PC less painful and then you can leave your browsers and applications to accept system settings.

That is cool that you speak multiple languages. I am receptive to a few languages but I would not say that I speak any proficiently except for maybe Japanese. I always admire polyglots that can move through languages seamlessly.

In regard to your browser changes, that may work. I have never needed to setup anything so complex. My only recommendation is to at least stick to one of each locale type. IE if you want to speak the Queen’s English (Or King’s now. I am sorry for your loss if you are into that type of thing) then keep everything in en_GB and try not to mix the different en_XX variants. Same for time and date.

Outside of that, you may have found a system bug and may need to report it up to the maintainers of your distribution.

1 Like

I always admire polyglots that can move through languages seamlessly.

it comes from having had a household of two languages that helps the infant brain to develop the language capabilities to learn and understand multiple, this is why children should be a lot in multi cultural and multi-lingual environments to be more, i guess intellect?

In regard to your browser changes, that may work.

Didn’t sadly.

You may benefit from a custom locale.

trying this now.

Queen’s English (Or King’s now. I am sorry for your loss if you are into that type of thing)

They are not of the Imperial dynasty(Napoleonic, Hohenzollern etc) and are not relevant were. And also wer userpers anyways.

My only recommendation is to at least stick to one of each locale type.

Is not about language but the formatting, id est I can’t read this “5-5-22”, is it the fifth of the fifth or the 22nd of the fifth of the fifth? or 22.12.12 like wtf is that supposed to mean. Like every time I would need to have the date written out because there are so many people that don’t stick to the standard DD.MM.(YY)YY
Then the currency is Pound Sterling which I do not actively have a value estimation for.
And time being an hour off.
And I’d get fed with some BBC news that I couldn’t care less about.

I created this OS, and it is in its infancy Beta versions. At some point I wanna distribute it, but I’d need to figure this whole Linux ecosystem in the first place, can’t have trash in modern system, like

YYYYMMDD is the one true format! Fite me! j/k

Oh. Maybe your issue has nothing to do with locale or TZ then. I don’t know where the issue would lie but maybe it is init related.

1 Like

maybe it has something to do with the bare os just has US keyboard instead of my Fi one.

Would anyone know where I can find a locale file I can use as template? Because I can’t find any help on the web.

The best I have for you is the Debian Wiki

And the Arch Wiki. This one shows you how to make local user overrides.

1 Like

I tried the 2.1 and 2.2 but well, locale still says: After restarting
Screenshot from 2022-09-20 14-22-03

Create a new user, log in and see what happens then. It may be that it is not touching your local user’s stuff because it has been modified.

Also, check to see what is in the /etc/skel directory. If there is a locale file in there see what it has as the defaults. You may need to do that and then re-roll your account; but you can test by creating a new account and see what you get. The skeleton directly has all of your system defaults to setup a new user account.