DAC/Amp not recognized - SOLVED (sort of)

So I have been using a a FiiO dac/amp for well over a year, I know I should get one from Mayflower but I have not been able to justify the expense yet. Anyways, just setup my new desk and did some major cable management and now the DAC doesn't want to work. It shows up as a playback device and everything looks like it is working but it doesn't have any sound. I have gotten it to work twice since the overhaul but it was after 15 mins of messing with it and then after the next reboot it is back to broken. Here is what I have tried:

3 different cables including the one it has been using for the last year.
Multiple different USB ports including switching between usb 2.0 and 3.0 ports.
Uninstalling device drivers multiple times and while on different ports.

I am running Windows 8.1, I have an Asus M5A99FX Pro Rev 2.0 Mobo. The DAC is the FiiO E10K.

No love... Any suggestions?

Is it plug and play or do you need a firmware from FiiO website?

It's plug and play, there isn't any software or drivers that you need.

Well I think I got it working after a couple reboots this morning. I wish I could say what I did that fixed it...