Dabbling in Linux, and it's off to a bad start. Any help?

*EDIT* Thanks to Dexter Kane, I read over the steps again and again and omitted one typo, which fixed it. Let this be a lesson to pay very good attention to directions.


Hi all


A few months ago I installed virtual box and decided to try out a Linux machine (Debain, to be exact.)

First of all, I am not very familiar with anything Linux and I will admit it. I'm pretty tech savvy and I know my way around some deep crevices of Windows but I'm a lost child in a grocery store for Linux.

So after a spell of installing just the basics and seeing a console window that was about as useful to me as the concept of a brick, I reinstalled the OS and got GNOME.

My problem was that I could not get the effing guest additions to install. I tried everything I found online in forums and finally gave up.

I recently had a bout of inspiration to give Linux another try, but this time I got KDE.

I still have the same problem. 

Whenever I try to run /media/cdrom0/VBoxLinuxAdditions.run as sudo It says "no such file or directory"

I even tried copying all the files to my documents and running the file by clicking it but it brings up a console window stating that it needs administrator privileges.

I also tried allowing root login for kde (which I knew was a baaddd idea but it was a virtual machine and I was desperate so whatever) but apparently /kdm/kdmrc  is "no such file or directory"

For god sakes, I even tried visudo (which got me nowhere) and then kdesudo, which still said no effing file or directory.

I'm starting to ragequit this and I really don't want to because I want to get comfortable with Linux for a plethora or reasons, but I need those guest additions installed!

Okay rant over, sorry. Does anyone else have an idea? I can't really move forward without fixing this problem so any help would be deeply deeply appreciated.

Thanks in advance, ~Tas.




This might help


I tried that method from that exact link at least 6 times :/ 

Everything worked except for the last two steps where I keep getting "no such file or directory"

Holy shit I'm going to facepalm my own face into a pulp I am so stupid.

All this time I've been typing cdrom0 instead of cdrom for steps 6 and 7. I took a minute to calm down, tried it again, read it extremely carefully, and it worked. 

Thank you! I'm sorry I wasted your time with my clumsiness. 

what about:

apt-get install virtualbox-guest-additions-iso

mount -o loop /usr/share/virtualbox/VBoxGuestAdditions.iso /mnt

ls -l /mnt

sh /mnt/<whatever the linux install is called>

umount /mnt

edit: command in wrong place

It seams you have not learned the use of the TAB key to autocomplete. Use it, for everything, its awesome.

So when it said no such file or directory what it meant was that there was no such file or directory? :P

+1 Using tab will save you so much time and trouble.

I guess so xD, and I will have to try this "tab" thing you speak of lol.

That sounds very helpful and also I have no idea what it means.

Lol, but I definitely would have tried it if I had not already gotten the problem fixed. Thanks for the help!

Just start typing and press tab, press tab twice to give you all possibilities.

For example this will list all the files in the current directory you can have the ls command list: ls <TAB TAB> 

this will autocomplete the directory home or list all options beginning with '/ho' (theres only one /home) ls /ho<TAB>

May as well explain it. 


# apt-get is the package manager for Debian on the command line. It does what it says, installs a package

apt-get install virtualbox-guest-additions-iso


# the 'mount' command will attach a device like partition, iso, etc to a point on the filesystem.

# in this case, a cdrom iso needs the special options 'loop' to act like a cdrom

mount -o loop /usr/share/virtualbox/VBoxGuestAdditions.iso /mnt

# ls lists a directory, the -l options lists the files in detail

ls -l /mnt

# sh - shell, runs shell scripts and commands, you specify where the file is you want to run a script from.

sh /mnt/<whatever the linux install is called>

# oposite of mount, its un-mounts the directory/iso/partition

umount /mnt

Wow that's actually really interesting, it makes me even more stoked to get into Linux!

Now that I've got that problem fixed I'm going to start learning the basics of debian and kde and the command line and what not. Are there any websites that may help me?

There was a free Linux course at edx.org, not sure if it's still going. Might be a good way to get a grip on the fundamentals.

Alright I'll check it out, thanks!