Crosshair VI Hero + Arch Linux + Dropbox = Crash

Yesterday I installed Arch Linux on my new Ryzen computer. I installed some packages from AUR, was setting up KDE, and the everything froze. After about a minute later, the lights went off on the motherboard, the DRAM qled started blinking and the qcode showed "8 ". At this point, only a hard reset can fix the computer. I haven't found anything in the logs.

What I noticed that this only happens if Dropbox running and syncing for a few minutes. Dropbox on Windows works fine.

Before installing Linux, I set up Windows 10 on a different drive (Linux is on an M.2 960 Pro, Windows is on a SATA 850 EVO), I ran RealBench in stress test mode for hours without any issues. Downgrading the UEFI from the beta to the latest stable makes no difference.

Any ideas where to continue troubleshooting? I would try different distros, but Arch is kind of a last resort: Ubuntu has an old kernel, so no sound card. Fedora 26 installs, but it gets stuck when it is starting services at boot. openSUSE Tumbleweed can't even boot its installer (I had the exact same issue with my laptop, something UEFI related).

1 Like

You really shouldn't be using dropbox due to lack of any semblance of privacy or security, unless you don't care about having either.

Meanwhile I am looking at different stress tests. I tried prime, bonnie, dd without any success. I don't know what kind of stress Dropbox puts on the system (maybe it is related to the drives?). I am running memtest right now, no issues so far.

Probably not much better than *boxes or *drives, but pcloud workes like a charm in arch (linux in general) :relieved:

NextCloud always works great, plus you own your data.

I would reseat the CPU and update BIOS, you never know.

that doesn't really have anything to do with the OP, really. i use Chrome on Linux, because i like Chrome. if something went wrong with Chrome, "use Firefox, it's more """""secure""""" is a pretty irrelevant thing to add.

All these issues are strange, have you tried Fedora 25? Its the stable recent release, unless you want bleeding edge. Also what are your PC specs?

Get latest bios, do 'pacman -Syu' (?)

Whats your memory setup like (make, model, bios settings etc)?

I do not see why it would not be relevant. If you are faced with a crashing system with the cause being a file sync utility, the easiest way to fix that is to not use that particular program, an even better solution is replacing it with something else so you do not lose the functionality.

What are your voltages (vcore, soc, dram) and ram speeds/timings? I've experienced instability on my Ryzen system when the aforementioned factors weren't tuned just right

you'd be right if it was some well known bug that absolutely could not be fixed and had documentation from several sources that the problem was insurmountable. i don't see that in here, but i do see you decrying a program because it's "insecure", while insinuating the OP should use something else if they like their data.

where's the evidence for this? what are your sources? if it's "that one time that one guy got hacked", which is an argument i've heard about 4,000 times in opposition from everything from Social Media to Smartphones, there really isn't anything the average consumer CAN do to protect themselves, because it can ALL be hacked/monitored ALL THE TIME. i do not understand the common argument coming from [largely] the "open source/linux" communities, that does nothing but breed paranoia over things largely out of anyone's control, by insinuating that if you get off Facebook and don't use Gmail, you're suddenly safe from everything and that nobody can monitor you.

moral wanking about aside, it strikes me as a bit rude to 1. comment on a thread relating to a program i assume you don't use 2. decry it and 3. do so in a way that might make people afraid when there's little need to be. that's just my opinion, though.

It has 4.11, and it is necessary for the sound card on my mobo.

Specs: ASUS Crosshair VI Hero, AMD 1800x, ASUS Strix 1070, G.Skill TridentZ 3200 MHz CL14 2x16GB kit, Samsung 960 Pro 512 GB (Linux), Samsung 850 EVO SATA 500 GB (Windows), Fractal Design Kelvin S36.

I tried with the latest stable and beta BIOS. I tried with a clean CMOS in both cases, as well as the memory set to the standard DOCP profile (ASUS UEFI reads the XMP, and "translates" it to the AMD platform). I haven't overclocked the CPU at all. I installed the RAM into the grey sockets, as the mobo manual suggested it.

The system survived hours of RealBench stress test (the CPU barely went up to 40C), and I ran a full pass of memtest86+ without any issues. On Linux, I wasn't able to reproduce the freeze with mprime or bonnie++. Only Dropbox triggers the issue.

My next move is to install Windows on the M.2 SSD, and run some tests there (downloading steam games + dropbox sync). This way I will know if it is a hardware or a software problem.

Stock, I haven't touched the CPU/SoC voltages. In case of the RAM, I tried with both default settings and DOCP (3200 MHz, but it raises the memory voltage to 1.35V, as it should).

Currently on Fedora 25 kernel , just do dnf -y update

or download the latest .iso with 4.11 kernel

I was having issues with the default SOC voltage of 0.9v on my motherboard so I raised it to 1.18v and that seems to have resolved all stability issues I was encountering. Maybe it's worth a shot trying that.

I had written a thoughtful reply but thought better of it. So I leave you with this instead: You can change the way people think, but not if you tell them that it is hopeless to make anything better, that pattern of thought is contagious and carcinogenic to society as we have seen time and time again in recent history and throughout.


The same freeze started to happen on Windows, but this time it is always during YouTube videos, after 1-5 days of uptime. I haven’t installed the spectre fix yet, because it breaks some ASUS software. If I run torrent, it happens faster.

The freeze happens here a bit slower, so I noticed that before the freeze the network dies (I have an intel wifi card in a x1 PCIe slot). Overclocking does not change anything, it happens on my overclocking settings and the stock settings.

My suspicion now is that something happens around the PCIe, and the OS loses access to the main drive (Samsung 960 Pro) or all drives.

Any ideas where to look? I think this is either the motherboard or the CPU, but I don’t know how to produce some kind of evidence to start the RMA process or figure out what to RMA.

I write the solution here in case someone finds this topic in the future: use the wifi card driver that comes with Windows, do not install the one from Intel’s website.