Crossfire 290x low fps Battlefield 4(after a bit)

Okay so after lots of testing I have come to the conclusion that it is overheating of the vrm's. If I underclock the memory and turn up the fan speed these black screens are almost eliminated. Sounds like I will have to install some waterblocks on these soon. An unexpected cost but it will be worth it i guess. -_- 

Yeah.  Overheating and noise was a huge problem on the stock R9 290s :(

Sorry for late reply. It died because it was just plain faulty, performance wasn't right form the day I got it then after a month it refused to work properly. I have since replaced it with an ASUS direct CU 2 model which performs about 25% better (proof that the previous one wasn't working correctly) and a hell of allot cooler and quieter.

Update after two months lol, still getting frame drops but only with Battlefield 4, 3, Crysis(demanding games). The black screens were from a bad DVI cable. I got fans setup that keep everything in line. VRM temps are in check. My 290x's run at under 90c. I just don't get it, I can play a round or two with the right frames and then pow down to 20 out of nowhere... Could it be my power supply not being able to feed the cards at loads?

 it looks like it may be because ULPS is active . It stands for "ultra low power state" it's supposed to tun the power off on your second card when you arn't using it to save power. It is supposed to turn it self off and return power to the second card but it is F#$%kd up and it malfunctions and causes your bottom card to load up and overheat ... .. you should disable it when using a pair in CrossfireX . ... It  may cause permanent damage to you GPUs. if you don't  Here is a link to more info about it and show you how to disable it ............

  You can manually edit your registry ... Or use the this  CFUtility

 ULPS Configuration Utility.    

Here are some different gpu monitors ...much more info in GPUshark and GPU Caps Veiwer

 To learn more about it Google   ULPS is active  and you can read for days

here is a thread from a few days ago

Its a cpu bottleneck.

If the ULPS is active it will cause these exact symptoms in crossfire systems


I wish mine were red ...  :(

yes ULPS is kinda fishy, But i know for sure that the FX8350 is not powerfull enough to drive two 290´s.upto its full potention.

Might be mobo Vrm's overheating ?

Or , your mobo can't supply the cards with the right amount of power via the PCI express lanes ( not expected ) .

Take a look at disabling ulps , my stock 290's had no problem with heat , the fan curve maxed out at 95°c , and vrm's where not throtteling 

You should know  ,,, you have the CPU .   But he should at least use the  GPU utility and under clock the GPUs if that is the case

My mobo sucks but temps are better than expected on all my parts. Mobo has supp molex connector for crossfire and it is connected as well. I tried disabling ULPS when this problem first started and it did NOT help. 

I have the same issue ... same CPU Running 4.6 ghz, 16gb Gskill Ripjaws on a Gigabyte 990 ud3 Rev 4.0 powered by a 1200w psu and 2 x R9 290 DirectcuII's with a custom fan profile and never gets above 68 deg Celsius, some rounds runs mint up to120 fps and drops to around 80ish in some places but then next round after loadin drops to 49ish with some hideous frame drops (hard to explain)  

Ps. Airflow isnt an issue as i have 2 200mm intake fans and a 140mm and 200mm exhaust fan and cpu is watercooled  all in a Thermaltake V71 Core case 

thats a cpu bottleneck. most likely. ☺

Which game are we talk about? single / multiplayer?

unless you can show us some monitoring data every post here is a guess.

my guess is that bf4 is a shit game programmed for consoles.

Really? Huh, weird, cause I run 2 290's overclocked to 1100/6000 without ANY bottle necking on my 4.7ghz 8350. How can you be sure there is a bottleneck? Have you tested crossfire 290's on an 8350? Or are you just assuming?


Is this video supposed to prove something that I am not seeing?

IF anyone reads this post, after everything it just turned out to be thermal issues and a CPU bottleneck...