Creating Linux Shares For Win10 & Other Devices

Hey guys!
I upgraded my media server to a mini PC with an external 4-bay RAID DAS that is connected via USB. My mini PC is running Linux Mint and I set up my fstab like this:

I am running Plex on the mini PC and I can access my library and share it via Plex clients. I add new media from my Win10 PC on the same network, so I shared my mounted DAS with Win10 and it appears to work as read-only until I copy something or delete something from the share and then I lose the share. I’m guessing it’s a permissions problem that anyone more familiar with Linux could spot instantly, but I’d rather not have to copy 8TB of data back to the array if I play around with it and mess things up. Here are some screens of my setup on the Linux and Windows sides:

Note that my Linux machine does not show up under Network, only my old Windows machine called MEDIA.
After I make any changes to the shared drive from my Win10 PC, this is what happens to the shared drive:

Once I get everything working as expected, my goal is to run my PMS on a headless Ubuntu Server install, which seemed very easy until I added the USB RAID enclosure. I was going to build an entirely new media server, but since I’m only streaming locally and I already had the G4 Mini with an i5-8500t/32GB RAM and 1TB NVMe, I just added two 4-bay RAID enclosures: one for media and one for backup.

Any help getting my share to work in Win10?

1 Like

Check ‘’/var/log/samba/?’’ for clues, also ‘’/var/log/messages’’

If you could give us the smb.conf too with the error logs. I don’t think ntfs is the best candidate for a share. The problem I would look at is ntfs uses access control lists and so you need to translate the Unix permissions to ACLs via samba. The way Linux does file permissions is completely different from windows, so you have to configure it as such.

Thank you Adubs & gordonthree. When gathering the logs to post here, I read them and decided to not use the GUI to make a share, but instead set it up in smb.conf. It is now working! My Linux PC still doesn’t show up under Network on Win10 and I’ve tried many online solutions, but my share is writable so that’s all that really matters.

1 Like

That’s not unusual for windows 10 and I haven’t figured out what causes it but my fix for this is to browse to things via ip \\ then I just map it.

1 Like

Same here, my Linux server doesn’t show up in the network browser under Win10… I put an entry in my hosts file in Windows so I can use the server name