Creating bootable usb flashdr. ISO Windows 8.1 on Ubuntu 14.04 HELP!

So I have tried GPT partition creating Fat32, Have reset my motherboard to boot from usb2 flashdrive, Secure boot is off
I used Gparted and then did Disk image writer and disk image mounter but also tried the ntfs Format and managed flags for boot and msdos.
So any suggestions how I can fix this? Want to be able to use Windows and dont care if ubuntu gets overwritten in the process. I can always install Linux later and dual boot but for now I really need some game time and Steam for Windows are the way to go for me today...

Not done it myself but I thought you could use gparted to set the boot flag then use archive manager to extract the ISO to the USB.

If that didn't work search for winusb and see if that would help you.

ok but can you explain the process in more detail about using archive manager cause what I did is I went into downloads/right click and open with disk image mounter/right click again open with disk image writer. Then I was able to see Devices on my computer

Try this then :

that should be able to get it done quicker than going through the manual steps here, steps that I am not sure will work mind you.

I cant Install Winusb. Have tried that.
This comes if I do that : : Failed to fetch 404 Not Found

W: Failed to fetch 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
I am on 14.04 Ubuntu and it is not supported anymore

I found the following instructions that might work on 14.04

sudo add-apt-repository ppa:colingille/freshlight
sudo sh -c "sed -i 's/trusty/saucy/g' /etc/apt/sources.list.d/colingille-freshlight-trusty.list"
sudo apt-get update
sudo apt-get install winusb

The second command looks like it tries to adjust the repository configuration to point to 14.04

I found these here:

Thank you but as I said it does not work. Have tried it several times yesterday

I tried and copy paste your command lines and it worked :) >> Well ok then next step is to use winusb ? although I read that it should not be used for Debian and ubuntu is Debian based right ? but I have tried so many things I have to try...
Have you used WinUSB and know how to ?

I have not used WinUSB before but it looks like the tool you need. In my case I can use windows to run their windows only tool to create a start up usb drive so I have not needed to use it before but I have heard of it.

It should be a case of selecting the iso file, selecting the usb drive and it should be able to do the rest.

tried Winusb but this came : Installation failed !
Exit code: 256
Formating device...
Error: /dev/sdb: unrecognised disk label

I have to go soon so I can't help much more today.

It sounds like the usb drive is unformatted or doesn't have a partition label.
Use gparted to enter a partition label on the usb drive.

Thanks for the help

Quick and really really dirty way:

  1. Check how's your USB drive called


it will show up on the list probably as /dev/sdb if you only have 1 hard drive or sdc if you have 2 drives

  1. Write an exact copy of your ISO file to the drive

dd if=/path/to/downloaded/win.iso of=/dev/sdX && sync

replace the X with the actual letter you found on the previous step

IMPORTANT: Remember to double-triple-quad check that the sdX letter is right. you can f* everything up with that command!

Also, after you're done with the USB drive you may need to create a new partition table and format it again (easy through gparted)

Hi Willdrick. I did one other thing about same as you described "sudo dd if=/path/to/iso/windows.iso of=/dev/sdb bs=4M; sync"

It did not work. Ok first of all I dont have the ,iso or windows.iso The link I was provided is mediacreationtool.exe and do I need to convert that to an ISO image and then HOWWWWWWWWWWW.

yeah, that mediacreationtool.exe is not an iso you will need to find one and check that it's valid. As far as I know you can't download them from microsoft any more.

I assume you have a valid windows key and you don't have an original copy because your computer had a recovery partition which you overwrote when installing ubuntu? Or something like that.

If that's the case you can try get the windows 10 technical preview, write that ISO to the usb drive, install that and from there you should be able to use the mediacreationtool.exe.