Return to Level1Techs.com

Creating a 2007 Retro Rig, constantly seeing 2nd CPU core floating 80%-90% usage in Vista 64bit, can't track down why [SOLVED]

I’ve reinstalled Windows Vista probably 20 times now, and two of those times it worked! Then ran into a issue with a chipset on the board and cause the whole thing to come crumbling down, restarted the whole OS install process and then ran into a blue screen issue, restored to a restore point and started seeing the issue all over again.

OS - Vista Ultimate 64 bit
CPU - AMD Athlon 64 x2 6400+
MoBo - ASUS M2A-MVP (on BIOS v0511)
RAM - (4x2GB) OCZ 800mt/s C4 Reaper
SSD - (changing soon) SanDisk 5000 32GB SATAI (waiting on OCZ 120GB SATAII drive to arrive)
HDD - Western Digital 1TB Black

I think that’s enough detail.

Loading the OS;
So, I can’t get my SATA optical drive to work. I have a USB optical drive, but for some reason either the CD Rom works, and the drives aren’t seen, or the drives are seen, but the USB optical drive doesn’t work. This may be a large part of the issue!

Workaround;
Pop the SSD in a older laptop w/ Intel Centrino CPU. Start the Windows Vista install, once it gets to the first restart point after preparing files, installing updates and features I power down the laptop, pull the drive, put it into the computer, and start it up to where it finishes the install.

Has it worked;
It worked two times since I did the above method of pulling the drive after the install. Except I ran into two issues;

  1. I installed a device driver which caused constant GPU driver crashes. (went back to fresh OS install)
  2. Started getting random blue screens, rolled back to a good restore point, but all of a sudden started seeing the 2nd CPU core being pegged once again.

How can I track down what hung/zombie process is pegging the 2nd core? Windows Task Manager shows NOTHING is using CPU time, I can’t get a command prompt string to show me PID’s and CPU usage, so I’m kind of stuck in a perpetual loop here.

Why Vista? It came out in 2007 like all the other hardware I’m using (aside from OCZ SSD and WD HDD) which is the whole point to the retro rig. Plus the hardware I’m using is no longer supported with newer OS’s, and can’t get older drivers to work.

Thanks for any possible help!

SOLVED - some how issue ended up being the chipset on the board. I replaced the motherboard with a different one, and issue is now gone.

I don’t think Vista has trim on it so you might want to look into third party garbage collection

Are you connected to the internet could be some kinda open port attack or some kind of vulnerability being attacked, or windows update might try and ping the server

Go into services and disable and stop the installer service and see if that changes anything

Try either Rufus or universal USB installer for a USB Vista install

Vista was released in 2006 but that’s just semantics really. I would still recommend 7 for this build because it matches the hardware better. Let’s not forget that Vista was an unmitigated disaster with behavior like you’re describing. Generally hardware support in windows was better a couple years down the road which is another reason 7 makes sense here. There’s also nothing Vista can do that 7 can’t.

The other problem is one of architecture. You’re installing Vista on an Intel laptop and then popping it into an AMD. Though they are both x86 CPUs, they are not interchangeable.

@GigaBusterEXE no internet connection.

@Adubs Win7 is the highest I can go, there’s no drivers for this hardware after that.

So I borrowed a optical drive from my parents computer. I was able to do a fresh install and no issues with core utilization. Smooth as butter! However, AMD’s Catalyst drivers crash so damn often it’s unstable. So I’m trying Windows 7 now.

1 Like

I think it will go much easier with 7.

@Adubs well it seems to be going smoother. Installing again, because I was seeing that odd 2nd core utilization issue again. Installed via optical drive connected to machine, so not a pass off install as previously done.

However, I got all the drivers installed without issue, and even with the odd utilization it still ran pretty good. Going to hammer at it a bit more, hopefully I get this figured out so I can get some games installed.

That didn’t last long. Still troubleshooting, but looks like it may be a bad motherboard.

Just ran UBCD to test RAM, CPU and such. Both CPU and RAM tested fine, no issues.

Changed GPU, and trying again but getting constant blue screen of death. May be a bad motherboard. I’m trying install with a different GPU and seeing if I get the same issue or not.

Ended up being the chipset on the motherboard causing all the issues. This is by far the oddest thing I’ve ever seen.

Aside from this, I’ve acquired enough parts to build two Retro Rigs, one for 2007 that’ll be a nice office piece once done and so I can let my kids see what I had to play when I grew up, and what got me to choose my career path, as well another one with all parts from 2009.

2007 Retro Rig I wish I had, a capstone year for me;
-AMD Athlon 64 X2 6400+
-4x 1GB OCZ Reaper 800mt/s C4 RAM
-MSI K9A2 Platinum
-4x ATi (AMD) Radeon HD 3870 512mb GDDR4
-SanDisk 5000 32GB SATAI SSD
-Seagate Barracuda 7200.10 750GB SATAII HDD
-Optiquest Q20WB 20" LCD 75hz Display
-Vista Ultimate 64 bit

The Retro Rig I’ll use for all my older games;
-AMD Phenom X4 965
-4x 2GB OCZ Reaper 800mt/s C4 RAM
-ASUS M4A78 Plus
-2x ATi (AMD) Radeon HD 4890 1GB GDDR5
-OCZ Vertex 2 120GB SATAII SSD
-Western Digital Black 1TB SATAIII HDD
-(I’ll use the Optiquest display for using this rig)
-Windows 7 64 bit

Can’t wait to finish getting these all lined out and ready for my new home office!

2 Likes