CPU Issue

Hey all,

I'm using an AMD FX-8350 with an ASUS Sabertooth 990 FX R2.0 Motherboard. The motherboard was recently RMA'd and I had the computer working for about an hour after I got it back but now the CPU light is coming on. I purchaced the parts back in Febuary and I can't find the warrenty information for the CPU so I have no idea if I can still RMA it. I was wondering if there are anyway to test the CPU either at home or by taking it to a shop, though I would perfer not to take it somewhere as best buy is the only store around me that handles computers and I don't want to be charged just for them to tell me it's broken and I need a new one. I don't mind replacing it but I would like to exhaust all my options, unless extremely risky, before I spend money on a new CPU.

My full computer specs are:

Motherboard: Asus Sabertooth 990fx R2.0

CPU: AMD FX-8350 Black Edition

GPU: Gigabyte HD 7870

PSU: Cooler Master GX 750W

RAM: Mushkin Redline 16GB (2x 8gb Sticks)

SSD: Kingston HyperX 120GB (boot device)

HDD: Seagate Barracuda 2TB


Any help or advice would be greatly apprecated.



Try running prime95 for 24 hours. It will tell you if it encounters any problems or not. 

I would love to try that, but the only problem is my system is not completely turning on. All of the fans turn on (CPU fan, and two other fans that I have) but nothing else turns on (GPU fans don't turn on). All that I have to go on is the CPU light on the motherboard. I have heard that prime95 is a good program to use though so thanks for trying.

One thing that I forgot to mention is that if I power on the system I cannot power it down by holding the power button, I have to filp the switch on the battery or unplug the system.

remove one of the sticks of ram and see if it will boot, if it doesnt swop the sticks around and try again (should rule out bad ram module).

ok, I tried it and still nothing


have you tried resetting CMOS (bios)?

I have not, I thought about it when it first happened but never did it. I'll try it though.

Are you sure that you have all of the power cables plugged in properly?

I'm sure I have all of the power cables correctly plugged in and resetting the CMOS had no effect.


Sure this one is plugged in? :P

It would be highly unusual for a CPU to work fine for a few days then suddenly brick itself.

Yep, that one is plugged in.

My first reaction to it was that the motherboard was dead again. but I saw the CPU light and figured I come find out what I could do to attemt to fix it as I know next to nothing about CPU errors.

Ok with the bios reset jumpers you made sure the power cord was unplugged and you put the cap over pins 2 and 3 then after a few mins you replaced the cap over pins 1 and 2 and reconnected the power chord to the tower?

If you dont have pins 1 and 2 covered the pc wont boot.

Yep that's how I did it.

ok, well im out of ideas im affraid, this happened to me on my old 775 board, i went through 3 CPU's trying to fix it and all did the same, flashed the bios aswell to no avail, tryed to RMA the board to ASUS they sent it back damaged. This is why i dont buy ASUS Motherboards anymore, gigabyte are my choice these days.

If you google around the net a few people have this issue aswell and as usual ASUS are no help atall, it seems to be a lottery with ASUS if you get a good board or a crappy one.

Hopefully someone can help you out, best of luck and sorry i couldnt help out more.

That's fine you did what you could,and I appreciate it.I'll keep scouring the interent in hopes to find an answer. Thanks for the help, have a nice day.

Could it be that the psu is bad and is screwing everything else up? My first thought was that the cpu aux power connector wasn't seated correctly or something. Maybe the psu is messing with the board. Do you have a way to test that? Another mobo+cpu combo, or another psu to drop in there?

I've tried another PSU already and there was no change. I don't have another mobo+cpu combo that I could try either.

I managed to get it to get it to POST, both by having my keyboard fully plugged in (two usb ports taken up) and by completely unplugging my keyboard (taking both USBs out). It said something like, the boot device is not recognized/compatable by/with the bios, and it told me to go into the bios to fix it. I could not get it to work following the instructions though, and I had to leave shortly after. It has now gone back to its original problems and will not POST, I have no idea what to do.


as a corrections to one of my other posts about the power not turning off when I hold the power button, it only refuses to turn off if the SSD is plugged in. If I unplug the SSD I can hold the power button and it powers down. This doesn't has no effect on the system however, it still does not post and the red CPU light is on.