Corsair Voyager Slider USB flash drive not detected by computer

My corsair USB flash drive just stopped working after I reformat it and quickly clicked stop during the process, now it can't be detected by the computer, is it dead?

Right click on computer, select manage, then navigate to Disk Management. See if the device is listed there. If it is, we can get it back, probably.

Nope, I can't see it.

Sounds dumb, but have you tried removing it and plugging it back in after a restart?

Yup, I even tried it on another computer and it didn't detect the damn thing, I guess it's officially dead, huh?

You could run Diskpart via CMD then run the "list disk" command see if it detects it.

Nope, nothing.


1 Like

I guess I'll have to buy a new one soon. Thanks for trying to help anyway.

Try downloading partition wizard, See if it shows up on there when you open the software. I have had a few of my customers un-formatted drives not show up in any windows management but would with wizard.

Sadly, it didn't work, thanks anyway.

Yep then Its dead for sure. :-(