Corsair K100 Air Wireless Keyboard

KVM Model:

1.4 Display Port KVM Switch - Single Monitor - Four Computer


I’m trying to use the Corsair K100 Air, either in wireless or wired mode. When connected to an HID port, none of my systems see it at all. When I connect it to the USB passthrough port it works, but it disconnects the keyboard and reconnects it each time I switch, which takes ~30 seconds for the OS to detect it and for it to start working. On MacOS, it launches the Keyboard Setup Assistant every time I switch to it, even after I complete it.

Is there any way to get this keyboard to just behave normalsauce? Unfortunately it’s the best typing experience for me so I’m sorta stuck with this model.

Thank you for reaching out! :slight_smile:

Unfortunately Corsair keyboards are known to be fickle with KVMs, your best bet is to try booting the keyboard into bios mode. It disables the proprietary Corsair software that doesn’t play nice:

Ofc the keyboard will also work fine in a non hid port like usb3 as well. Even with the fancy rgb nonsense. But it can not work in hid when its in rando non standard rgb mode.

Ah true I assumed he was wanting hotkey compatibility

Thank you for the replies. Unfortunately BIOS mode was unsuccessful, it still is not seen by any of the computers connected to the KVM.

The usb3 has the following issues:

  • If a PC goes to sleep while I have switched away to another computer, the keyboard can no longer awaken it from sleep because it was disconnected when I switched
  • It takes ~10 secs for the keyboard to be recognized by a computer when I switch to it
  • MacOS launches the Keyboard Setup Assistant every time I switch to my Mac Studio.

Are there any known workarounds for any of these issues?

None of those are known issues, and I’m pretty sure we have people using that keyboard just fine via usb3, which suggests a problem with your setup.

Have you tried different upstream ports on the hosts? A long switch time suggests that the keyboard is not in the same mode on each host. Does each host have corsairs wacky funtimes rgb software installed? if not that would probably help a lot.

For diagnostic purposes have you tried uninstalling all the corsair software?

Finally if you’ve tried the keyboard port in a hid port previously unplug the kvm from power and usb for one minute. The kvm will “remember” that the device “wanted” to be a hid device (but doesn’t realize it is lying). So if you start from a fresh boot of the kvm in usb3 that may have a different outcome than what you’ve experienced so far.

1 Like