Return to Level1Techs.com

Connect one wireless router to another to create a private network

I have a Linksys WRT3200AC Home’s main modem/router combo is some Netgear combo unit. Ip is 192.168.0.1/24

Is there a way to have my WRT connect to the home’s main wireless router (wirelessly) so I can run my own private network under 192.168.1.1/24 and run my own DHCP server and NAT?

bask in my superior mad drawing skills

You will need to use client mode on the WRT if it supports it, you might need to install third party firmware. Installing DD-WRT on Linksys WRT3200ACM - YouTube

That is called a wireless bridge.

1 Like

The factory firmware has the option for Wireless bridge mode. That’s what I’m looking for?

Yes, you need to use the SSID and password for the other router.

1 Like

I enabled that and got it connected, but doesn’t solve my problem.

I don’t have the option to create my own network. It’s basically just a repeater but with a different SSID now. I’m still on the .0.1/24 range from the home router, but I want my own .1.1/24 where I can run NAT and my own DHCP on my little network that’s attached to the main router for internet connectivity.

No, “wireless bridge” is not “client mode”, but “client mode” aka. “station mode” is what you need.

Essentially your wrt3200acm just needs to behave the same as your phone or laptop would over WiFi.

OpenWRT on WRT3200acm can be made to do this easily through the web UI. docs


In many ways it’s actually a pretty good use case for the crappy wifi firmware Marvell used to stab us in the back.

2 Likes

I’m familiar with flashing FW on it. I used to have DD-wrt on it, but reverted back to stock.

Will DD-WRT do this or just Open-WRT?

Most likely yes, I haven’t used dd-wrt since 2010… with openwrt I know it works. (I have the device and have used it for various wifi stuff, incl. as just a wifi client for a good bit).

1 Like

THANKS!. I’ll give that a go.

Basically my end goal is I have a pihole that I want to use as a dhcp server and ad blocking for only my personal devices and everyone else can f off and connect to the home main router.

1 Like

You don’t technically need a separate network for that, you could have pihole acting as DHCP and DNS on your one network, and you could configure whether to filter DNS based on who the client device is.

https://docs.pi-hole.net/database/gravity/example/

True, but I only have access to the home network as a client but not the admin page, So I’d rather create my own.

1 Like

Got it working, my only question is, in my PiHole, my query log has every request coming from the OpenWRT address rather than the individual devices. any way to fix that?

You probably want pihole attached to openwrt and then pihole acting as the DHCP server, and DHCP server on OpenWRT disabled.

(other alternative setups are possible too, e.g. you can selectively disable nat in openwrt and setup a static route on pihole to send replies back through openwrt; and others)

1 Like

I think I fixed it, Went into the optional DHCP server and inputted my pihole IP with a 6,before it like so

6,192.168.1.137

I don’t understand the need for the 6 but hey it worked.

For anyone who needs it

I always add what helped me fix my problems, since I HATE coming across IT forums and it ends with “nevermind, fixed it” without saying what fixed the problem i was searching for lol

I couldn’t figure out how to make the PiHole as the DHCP server without breaking everything, but at least my DNS ad blocking works.OpenWRT is a little confusing.

Also, I couldn’t get my desktop PCIe wifi card to connect but my other devices connect. No Idea why, just says “cannot connect to this network”

ethernet works fine though, and my phone and laptop connect wirelessly just fine.:woman_shrugging:

When your device requests an IP address and configuration form a DHCP server, DHCP replies with a packet full of various “Options” containing the IP address, router address, DNS address, and potentially many other things in a reply that has a structure of these repeating “Options” fields.

Option “6” happens to be for DNS - your setting will override what OpenWRT (which relies on dnsmasq for DHCP and DNS) is using for option 6, leaving other stuff intact.

Option “3” is the router /gateway if you want to override it for whatever reason… Wikipedia has a table with common stuff:


You should be able to see your desktop wifi card in openwrt logs, potentially you could change the log_level to be more verbose in /etc/config/wireless if you’d like to see more stuff… or look at what’s your desktop complaining about in more detail (not sure what OS you’re using, there’s probably logging somewhere).

1 Like

How did you setup your wifi? Did you enable WPA3, krack countermeasure or 802.11w management frame protection? If yes change it to WPA2 disable krack and set …w to optional

I didn’t enable those, its wpa2-personal and set a password, kept all other options to default.

using win11, the pcie card is a tplink ac card.

Not sure how to get windows to tell me anything more about why.

Might be a driver bug then. You could test it by using a Linux live distro.