Computer not posting while upgrading to ryzen 5000

After saving some money over the last year or so I decided it was time to upgrade from my old i5 4480.
My new parts are:

  • Ryzen 5 5600x
  • 32 GB Corsair Vengeance LPX (4 x 8GB @ 3000MHz)
  • ASRock B550M Steel Legend
  • Western Digital WD Blue SN550 NVMe SSD 500GB

I am also reusing a RTX 2070 super which was my previous upgrade, my PSU which is an EVGA supernova 550 GS, 1 x 1TB SanDisk SSD, 1 x 1TB HDD, 1 x 120GB SanDisk (old boot drive). Of the various pieces of storage I have, only the NVMe drive is connected at the moment.

So far I have checked all 4 sticks of RAM, none of which seemed to be the problem. This is supported by the post status checker lights on the motherboard. This consists of 4 different lights labelled BOOT, VGA, DRAM, CPU. According to the manual these show that a part seems to be dysfunctional when they emit a consistent red light. In my case the CPU and DRAM lights are not lit, indicating their functionality, whereas the VGA and BOOT lights are initially unlit then turn on as the fans spin down to a slower idle speed.

So far my troubleshooting has been rather sporadic as due to my inexperience I am mostly doing it based off information on the internet. Other than checking the RAM and clearing the CMOS by reseating the CMOS battery.

While I use computers a lot and enjoy a bit of programming, however other than changing my GPU I was much younger the last time I worked with any hardware. Any help would be greatly appreciated!

Well i suppose your problem is likely that,
your motherboard needs a bios update before it will work with the 5000 series cpu´s.


I’m not sure how to do this? I thought you had to be able to get to BIOS in order to update to the newest version?

Have you tried taking it apart and putting it back together again? /s

I am looking at your manual, does your board not give any post codes?
If it’s your gpu, try reseating it (take it out and put it back in)

Try using only 2 sticks, if that fails drop to 1 stick of ram. Ryzen prefers dual channel over quad channel ram.

1 Like

I´m not fully sure if Asrock has bios flash back or similar support,
on this particular board out the top of my head.

I need to check that out.

1 Like

Shouldn’t b550 come with support for ryzen 5000
Forgot b550 came after ryzen 3000, other boards do

In specifications section

The b450 version doesn’t have it

1 Like

While I’ve been messing around I’ve had to take the GPU in and out multiple times, so I’m fairly sure it isn’t the problem.

Here’s a picture of the post indicators on the motherboard. While it’s not very clear, the DRAM light is not on it’s just got light bleeding over from the VGA light.

Try checking the ram

This reddit user had boot issues

1 Like

Well yeah kinda depends when the said board got shiped out.
The boards that are shipped out today likely have an updated bios already.
But in regards to the retailers you never know how long the said board has been in stock.
So if it actually is one of the first batches, than you could be unlucky.
Because B550 was way before the 5000 series cpu´s eventually came to the market.


I see, I’ll try playing around with the RAM some more as bedHedd suggested.

Always worth a try.

Not sure where you boaght your stuff from?
If it is in a local shop i would just go to them,
and let them flash the bios.

I don´t think that this board supports flashing a bios without supported cpu.


Unfortunately not, bought off of Amazon. If worst comes to worst I’ll just have to go to a shop, though I’d like to exhaust the self troubleshooting steps first.

I’d see if you can get the boot codes, I can’t find anything online about the led meanings.

Without being there in person or over video chat I don’t have any other guesses

Alternatively, you can call some shops and see if they will do a bios update for you

1 Like

Sure that is always the right spirit.
Because i could also be totally wrong of course. :slight_smile:

1 Like

To be honest I’m not sure how I would find the boot codes? This isn’t a mb with a mini display which shows them.

I was looking at the wrong mobo manual.

There isn’t much documentation on the led for boot, just that if the light is on it, there’s a issue.

Based on that I assume it’s a issue with the bios. Try a different graphics card or slot to see if you can clear thr vga issue

1 Like

One thing you could also try to do is.

  • unplug it from wall power.
  • Take the bios battery (which is on the board) out for like 30 seconds.
  • Put the battery back and power it on again.

This will result is hard clear cmos.

1 Like

I’ve now tried all four sticks of ram in all 4 slots and cleared the CMOS, but the post issue remains unchanged. I don’t suppose there’s any other possible fixes, because at this point I’m looking at a potentially pricey repair shop check up. Either way it’s 4 in the morning for me so I’m gonna let it rest for now, thanks to both of you for the help!

Yeah well normally a good willing computer repair shop,
should be doing a bios flash for you for just a few bucks.
I mean it´s really nothing more then just drop in a Ryzen 3000 series cpu,
boot it, and flash the bios from within the uefi.

Nothing more nothing less, probablly a 5 minut job.

With certain boards you could do this yourself without needing a supported cpu installed.
Like certain Asus, Gigabyte and Msi 500 series boards have such a bios flashback like feature.
But i suppose that Asrock does not has the said feature included on that particular B550M Steel legend board which is of course a pity.