Return to Level1Techs.com

Complete N00b Needs help troubleshooting GPU passthrough on Ubuntu Host

For starters; this is my first post so whatever moderation is around feel free to move it if this isn’t the correct section.

I’ll start with the Hardware Configuration
Host GPU-Nividia Quadro NVS 295
Passthrough GPU-AMD Radeon Vega 56
CPU’s- 2X Xeon E5520 Quad-Cores W HT enabled
Memory-32GB ECC Registered DDR3 @800mhz
Storage- 1 2TB HDD @ 7200RPM

OS is Ubuntu 18.0.4 LTS
And i’m (Attempting ) to use KVM to actually spin up the VM and pass the GPU and it’s Audio device to said VM. They’re on seperate IOMMU groups for some reason.

Finally a description of the issue.
So after getting to the part where i entered “lspci -nnv” and seeing vifo and amdgpu i thought i was golden.

But whenever i attempt to actually make the VM with the GPU and audio device it throws the following

Unable to complete install: 'internal error: process exited while connecting to monitor: 2019-09-26T04:22:43.468877Z qemu-system-x86_64: -device vfio-pci,host=05:00.0,id=hostdev0,bus=pci.0,addr=0x6: vfio error: 0000:05:00.0: failed to setup container for group 14: failed to set iommu for container: Operation not permitted’”

iv’e scoured the internet for solutions; set user permissions and even added config files. The only thing i can think of is the following message still perists when attempting to run the following command “sudo update-initramfs -u”

“update-initramfs: Generating /boot/initrd.img-5.0.0-29-generic
W: Possible missing firmware /lib/firmware/amdgpu/vega20_ta.bin for module amdgpu”

However it seems to work; otherwise i wouldn’t have been able to get IOMMU enabled and the vfio driver to capture. So i don’t think it’s the issue; help appreciated.

LGA 1366 often needs options vfio_iommu_type1 allow_unsafe_interrupts=1 in /etc/modprobe.d/iommu_unsafe_interrupts.conf for passthrough to work. Then update initramfs, reboot, and try again.

Also, could you post your IOMMU groups?

1 Like

Plain text enough? can’t post images i’m afraid
EDIT-That…worked…i…
Thank you so much

1 Like

You are very welcome.

1 Like