Code 43, I thought nvidia stopped this

I am getting code 43 with my 1050ti. What is causing this? I thought nvidia stopped this for their devices. I am using proxmox btw.

AMD CPU, 1050ti.

This can be caused if there aren’t enough resources (addressing space) which shouldn’t be a problem with a 4GB 1050 ti what’s complete system specs

Resizer bar enabled?

1 Like

amd 5950x
1050ti
gt 610
gigabyte aorus elite 2
64gb of ram

no resizer bar enabled.

Try enabling it and toggle above 4g decoding see if on/off helps

1 Like

will do. I thought it might be the bios. Enabled resizer bar and now windows just freezes on boot.

Enabled resizer bar and now windows just freezes on boot.

stays like that.

I will try creating a second vm to see if i can make it further.

You need to convert your disk to GPT for resize bar to work. - from memory

Still freezing after converting vm to gpt.

You are blacklisting everything correctly on proxmox yes?

[email protected]:~# ls /etc/modprobe.d/
blacklist.conf                kvm.conf                      tuned.conf                    zfs.conf
iommu_unsafe_interrupts.conf  pve-blacklist.conf            vfio.conf
[email protected]:~# cat /etc/modprobe.d/blacklist.conf
blacklist radeon
blacklist nouveau
blacklist nvidia
[email protected]:~# cat /etc/modprobe.d/kvm.conf
options kvm ignore_msrs=1
[email protected]:~# cat /etc/modprobe.d/iommu_unsafe_interrupts.conf
options vfio_iommu_type1 allow_unsafe_interrupts=1
[email protected]:~# cat /etc/modprobe.d/pve-blacklist.conf
# This file contains a list of modules which are not supported by Proxmox VE

# nidiafb see bugreport https://bugzilla.proxmox.com/show_bug.cgi?id=701
blacklist nvidiafb
[email protected]:~# cat /etc/modprobe.d/vfio.conf
options vfio-pci ids=10de:1cb2,10de:0fb9 disable_vga=1

And then you have to manually edit the vm’s conf file and add hidden=1.

Ex.

vim /etc/pve/nodes/pve/qemu-server/401.conf

# add hidden field to cpu area
cpu: host,hidden=1,flags=+aes

And then add the PCI-E devices (for everyone these ID’s will be different)
Screen Shot 2022-05-18 at 6.05.39 PM

I have not blacklisted radeon. I don’t have radeon gpus in the system. I will do that.

This is the tutorialk i followed.

1 Like

So I think I solved it. That tutorial I linked does scisi for virtual disk. This time I chose sata and it works. I mean no freezing.

1 Like

Nope froze again… After I installed the gpu drivers it froze.

I narrowed it down. It is when it is selected as pcie. Boots fine when it is basic pci.

Try giving it a VBIOs, or if it already is giving one, then give it nothing.

If I recall correctly, my Quadro M4000 give code 43 (which is a generic error that can be produced by many possible things) if it is given a vbios.

My RX 6700XT on the other hand requires one.

I am getting this output.


kvm: -device vfio-pci,host=0000:07:00.0,id=hostpci0,bus=ich9-pcie-port-1,addr=0x0,rombar=0: Failed to mmap 0000:07:00.0 BAR 1. Performance may be slow

It works with amd gpu but not nvidia. go figure. Both 1050tis i have dont work, the amd gpu worked first try.

With the 6500xt i am getting


Failed to mmap 0000:09:00.0 BAR 0

so an update, i got gpu passthrough working on popos to windows. still no luck with proxmox.