CISCO AnyConnect + GNU/Linux (Mint 18.1) [solved]

I'm going to keep this short and simple. I need offsite access to my University's cluster servers so I can work on *.nii files from home. *nii files are variants of the NIfTI-1 format, which are generated by 11T fMRI scanners. They tend to be astronomically large in size, transferring them takes time, and the scanner directly uploads them to the secured lab servers.

I use SPM running within Matlab running within GNU/Linux to manipulate and analyse them. This requires using the CISCO AnyConnect to access the network from off campus, and X2GO to access the system they are stored on.

I am wondering if the CISCO client works on Mint 18.1, or if there are ways to get it to work in 18.1 (based on Ubuntu 16.10)? Because from what I can find online, it is supposed to be supported only in Ubuntu 12.04 and 12.10 (for 64 bit systems) and Red Hat x 64.

I don't want to do this using Windows because the SHELL is terribly productive in working with megasized files of this kind, and VM setups for this type of operations cause unbearable lags in processing the data.

Are my options limited to downgrading to Ubuntu 12.10??

Is it a .deb file? Because you can get it to work on Mint if so.

1 Like

The client download site provides *.tar.gz downloads.

So what happens when you run it?

It supports most LTS distros

Red Hat 6 (64-bit)
Ubuntu 12.04 (LTS), 14.04 (LTS), 16.04 (LTS) (all 64-bit)

That should include mint (probably), CentOS, Fedora (probably), OpenSUSE, etc.

1 Like

The Client should be in the repos of your distro. The tarballs are for "obscure" distros.

It should be in the main repos, if it is in the main of Fedora (which it is), then there usually is no "political" obstacle for it lol

3 Likes

You are correct it's in the Fedora repo.

[[email protected] ~]# dnf search anyconnect
Last metadata expiration check: 0:22:00 ago on Fri Mar 10 10:27:05 2017.
==================N/S Matched: anyconnect ==============================
openconnect.x86_64 : Open client for Cisco AnyConnect VPN
openconnect.i686 : Open client for Cisco AnyConnect VPN
2 Likes

I use openconnect on Arch and can connect to my works cisco vpn no problem

EDIT: arch wiki entry
https://wiki.archlinux.org/index.php/OpenConnect

3 Likes

hmmm... It looks like the mint repo contains the open client for connecting to Cisco VPN! I will give this a try and let you guys know if there's something else broken...

   [email protected] ~ $ apt-cache search anyconnect
libopenconnect-dev - open client for Cisco AnyConnect VPN - development files
libopenconnect5 - open client for Cisco AnyConnect VPN - shared library
libopenconnect5-dbg - debugging symbols for the libopenconnect5 shared library
network-manager-openconnect - network management framework (OpenConnect plugin)
ocserv - OpenConnect VPN server compatible with Cisco AnyConnect VPN
openconnect - open client for Cisco AnyConnect VPN
openconnect-dbg - debugging symbols for the OpenConnect VPN client
[email protected] ~ $

Meanwhile, enjoy this picture of a fuax pas! Someone left a metalic object in the MRI room, and... well... you can see the results. Takes about 20 men to pull that chair off...

2 Likes

All right! The openconnect thing worked like a charm, and X2GO did not cause any issues at all! Thanks a lot for all your answers, folks!

1 Like