Return to Level1Techs.com

Checking Out The AMD Radeon VII! (Great for Content Creators!) | Level One Techs


#1

http://www.amazon.com/dp/B07NFGDZWQ/?tag=level1techs-20


This is a companion discussion topic for the original entry at https://level1techs.com/video/checking-out-amd-radeon-vii-great-content-creators

#2

That’s hIgh praise for this card, and from the looks of it warranted!

Am considering it for my next build with Zen 2, if it can do 1440p/2160 that well I might replace my old monitors too.


#3

https://www.newegg.ca/Product/Product.aspx?Item=14-202-330&cm_sp=SearchSuccess--INFOCARD--AMD+VII--14-202-330--2&Description=AMD+VII

$929 and 3 free games and it can play what I want to play at 4K like a GTX 1080 Ti can = winner in my books. Unfortunately at this time don’t have the money to buy this but others can and are getting a good deal while also not supporting Nvidia. Yes I would actually love to buy this right now just to stick it to Nvidia. Also if my GTX 670 dies I will be going AMD still but with a lower tier card.


#4

Looks like a great GPU for productivity without any cons for gaming, also being future proof having 16GB VRAM. When found close or below its MSRP, it is a great option.


#5

I bought one and, while the rendering benchmarks show great results, it has an issue with UEFI on boot. I have a dual-boot Win 10 and Ubuntu 18 LTs setup using grub2. Often (4 out of 5) I never see the ROG logo (Zenith Extreme Alpha/ 2990wx, 128GB) or the grub2 menu. The log screen with option to invoke EFI with Del or F2 never appears, monitor times out, the grub2 menu never appears, and the system boots straight to Windows 10. This is annoying for OC tweaking. It takes multiple restarts to get a chance to enter EFI for OC tweaking.

I tried both an EVGA 1080ti Founders Edition and an EVGA 1080 FTW 3 and both boot reliably to the EFI ROG logo screen every time. And then to the grub2 loader every time as expected.

I flashed the BIOS with the AMD update to enable EFI three times. But still have this problem.

Anyone else experience this? Do I have a flawed GPU card or something else?
Anybody have any suggestions on why the Radeon VII (Sapphire) might be slow to provide video on boot and how to troubleshoot and fix it?


#6

I don’t think you have a flawed GPU. I’ve experienced the same on various Vega 64 cards. Using HDMI during bootup seems to reliably get the EFI boot screen showing for me. So I just switch to HDMI whenever I need to access the BIOS. It might be some kind of issue with certain monitor combos only, with my older monitor, I never noticed this kind of behavior with DisplayPort.

If anyone knows of a better fix/workaround, I’d be interested though.


#7

Quick question. In the R-VII review by LV1techs Wendell mentioned that with the specs this graphic card make it a competent gaming card but it had way more potential. Does anyone have hands-on experience with ROCm with TF using Keras on the Radeon VII? Has anyone used this open eco system for direct GPU calculations? I assume that Wendell had to send back the R-VII back…maybe we need another Sapphire Ed guest appearance?

I’ve been stuck in the Nvidia ecosystem since sandy bridge days and there appears to be some options.


#8

A shame AMD didn’t advertise this as a workstation type GPU like the Titan class GPUs are. Would have looked a lot better than being a late GTX 1080 Ti competitor in gaming.

Drivers being super solid on Linux is great to hear. I won’t really need this level of performance anytime soon though and I don’t have $700 for a GPU, by the time I do new GPUs will be out.


#9

Well Titan’s are also still sold as gaming cards arent they?
AMD advertised their Vega Frontier edition cards are workstation cards.


#10

I thought of that and, a bit miffed over the silliness, dismissed it though now I think I should have tried it. Interesting that a “compute/render” card doesn’t support the “gaming” video I/F but I guess that makes sense. I RMA-ed mine today, but if the replacement has the same problem, I’ll just try HDMI. It has great specs and Linux support and I assume it will end up a bargain for the price in the long run. Navi looks to be less capable from the early benchmarks. Those who waited (unless gamers) will be regretting it.


#11

Marketing…they ruin EVERYTHING… :wink:


#12

If the 2080 really has a VRAM issue in Rise of the Tomb Raider (*), then leaving it out is not entirely fair. Also, while you mention it works on 8GB of VRAM it should also be noted that a Vega 64 has HBM2 vs a 2080’s GDDR6. HBM2 might help to alleviate this issue.

*) something similar is mentioned by AdoredTV


#13

eeenteresting. I just assumed it was a driver issue because the 41x.xx drivers from nvidia have been… umm… interesting lets say? I think even a 1060 6gb is basically ok for medium-high 1080p on TR but the geothermal valley was def. using more than 8gb on the 2080. So it’s probably just a bad case statement in the driver or something. I’ve given AMD a pass on similar driver bugs on their side too, as they tend to be fixed pretty quickly once pointed out.


#14

the HBCC, wich may be able to work arround any VRAM limitation.


#15

I RMA-ed a radeon ViII from Sapphire that would only boot from HDMI. Using any of its display port resulted in POST failure with HDD detect errors or sometimes it would skip EFI and boot straight to Windows. The HDMI port showed no such problems. A substitute of a FE 1080ti (EVGA) showed HDMI and DP ports all behaving as expected. I bought the Sapphire because all the well-known vendor models of the Radeon VII were sold out (I favor EVGA as they’ve never sent me a lemon to date). I hope the replacement Sapphire card works with all ports. I am not paying $800 for a flawed or unreliable design by a vendor.


#16

I’m not benchmarker and my personal experience is limited at best. If this issue can be fixed by a simple driver update, giving nvidia a pass won’t hurt anybody.

Further testing could point to the origin of the problem, e.g. 8GB GDDR5(X)/6 vs. HBM(2) vs. More RAM


#17

so the question is . . . how did Sapphire do on the RMA front? Was the return process smooth? Are they getting you a replacement quickly? Bad hardware happens, it’s how the vendor handles it that matters to me the most.