Centos 7 Update Crash

When I ran application installer update on Centos 7 on reboot the command line hangs with this prompt

Stopped Switch Boot
Started Update UTMP about System Runlevel Changes

I’m sure this has something to do with NVIDIA Drivers, when I was searching forums to install drivers I heard dangers of updates breaking drivers if installed improperly on some level.

Some interesting notes

kernel 4.18 hangs at boot
but 3.10 boots with NVIDIA drivers which doesn’t make much sense because NVIDIA Driver wouldn’t even let me install on Kernel 3.10, I doubt it’s stable and I should be on the new kernel anyway.

I’m wondering two things

Can I back out of update in the command line, I believe alt + F9 or alt + F2 loads a second command line, but I don’t know what to enter to restore working version of the kernel 4.18.

Also how do you install updates with out bricking kernel

Thanks for any help

I’m running Centos 7 because that’s supposed to be the officially supported distro for Davinci Resolve a video editor. I’m videographer and editor for my 8-5 job so I figure I’d I use the distro Blackmagic Design officially supports. Also excited to get some emulators running and try out the new steamplay and wine.


Any chance you are running wayland?

Sorry I don’t know what this is

system is
gtx 1060

I installed kernel 4.18
kernel source
and NVIDIA Linux Drivers

Didnt know there was any 4.x kernel with Centos 7.x

1 Like

CentOS 7 uses kernel 3.10.somethingsomething. How/why are you using 4.18?

1 Like

Since wayland is known for breaking on nvidia drivers,
you should check if you are on xorg or wayland first.

An explaination on how to check what you are running is given here: https://unix.stackexchange.com/questions/202891/how-to-know-whether-wayland-or-x11-is-being-used

when I run <loginctl show-session 1 -p type> I don’t get anything

What’s the output of: systemd-loginctl list-sessions ?

1 0 root seat0

sorry missed typed here and command line, I got it

says Type=tty

How are you on kernel 4.18 when centos is 7.x is still on 3.10(16?)?

Centos 7 Kernel Update

ahh I see.

I don’t know I might just mess around in kernel 3.10 for now, NVIDIA Drivers are still up so thats enough for me.

Kernels are interesting its almost like you have multi versions of the same OS if one breaks you can hop to another

centos is meant to be a stable platform for services.

It is not mean to be bleeding edge. You’re better off with fedora IMO.

That’s weird, if you are running a second console you should see two sessions.