.cap bios file name help for ECS LEET GAMING Z790H7-A(1.0)

Hey anyone know the bios .cap name for ECS LEET Gaming z790h7-a? I asked on reddit and got some suggestions but none worked. Also tried ami.cap spi.cap lg.cap h7a.cap… contacted ECS support waiting on response.
Reddit reply from u/HueSplat
I saw your post yesterday, searched for hours and found no info at all other than it seems to be ECS’s first consumer motherboard for a while.
Older ECS boards appeared to have the same bios flash button but I found no mention of how to use it anywhere.
All ECS FAQ and help information on bios updates seems very outdated.

I highly recommend contacting ECS support, repeated attempts could possibly cause a problem (although it shouldn’t).

there is a reference to “EBOOT.ROM” in the bios recovery image, but honestly that means nothing at all.

BUT, If you wanted to randomly try, rename it to:








Try leaving it .cap or changing it to .rom or .bin for each.

1 Like

I’m honestly surprised ecs is still making stuff, gonna have to wait on support since their documentation is so garbage


Yeah, it’s pretty crazy, I tried every kind of search term I could but found nothing at all, couldn’t believe it.

Besides ECS support, I thought possibly someone here might know.

(I’m huesplat, the guy trying to help)


This sucks

Got this reply from support
Dear Sir/Madam
If there is no information in the manual, it means that the USB port of this motherboard does not have the ‘flash back’ function. You can update the BIOS according to the SOP, please download the SOP according to the following figure

Sop is a pdf showing how to update bios in uefi with usb. Im trying to do a cpu-less flashback and the bios update feature is advertised

Wow, that’s not the best response!

Besides mentioning the button in the manual and the manual also mentioning the specific usb port.

You can also mention their press release states “ The Z790H7-A motherboard adopts one-click BIOS update, which solves the complicated and cumbersome BIOS update problem for gamers.”

Although, technically they do not mention that it works how one would assume (no or unsupported CPU/RAM).
Maybe the flash button literally just boots to an in built flash utility and it does not have the ability to flash without a supported CPU etc?

Ill try press them is that its quoted in the manual. i’d assume it works as normal cus usb is blinking on update button press. Gonna try a few more usbs and see if they work any different but i also ordered a ch341a to flash the chip manually.

I can’t find any reference to this feature in the manual, the only mentioning I can find is “Add the function of copying BIOS parameters to USB flash” which is not the same as flashing bios.

@Unestablished how did you go? Any luck?