Return to Level1Techs.com

Can't Install Rust

I'm trying to learn a bit about Rust so I was trying to install it on my Raspberry Pi Zero W, however, when running the install command they have on their website it fails every time.

After running curl https://sh.rustup.rs -sSf | sh and selecting 1) Proceed with installation (default) I get

info: syncing channel updates for 'stable-arm-unknown-linux-gnueabihf'
error: could not download file from 'https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256' to '/home/pi/.rustup/tmp/rsx39ozucyupb6qg_file'
info: caused by: error during download
info: caused by: [1] Unsupported protocol (Protocol "https" not supported or disabled in libcurl)

I have tried uninstalling and reinstalling curl, same thing. Reboots haven't fixed it. It seems to run that the curl https://sh.rustup.rs -sSf | sh just fine which uses https... not sure what else to do.

Edit: Oh and when this is the output of curl -V

[email protected]:~ $ curl -V
curl 7.38.0 (arm-unknown-linux-gnueabihf) libcurl/7.38.0 OpenSSL/1.0.1t zlib/1.2.8 libidn/1.29 libssh2/1.4.3 librtmp/2.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smtp smtps telnet tftp 
Features: AsynchDNS IDN IPv6 Largefile GSS-API SPNEGO NTLM NTLM_WB SSL libz TLS-SRP

Edit 2: I was able to install it using a standalone installer from here, but I would still like some help with the default installer, it would be nice to get that to work.

I'm pretty sure you can get visual studio code or gnome builder and just do it that way.

since its just a shell setup file, open it with nano or vim and where it goes to download the files from the https site change it to http and then it should work fine.

I just SSH into my Pi, no desktop environment is being run.

1 Like

So I've tried doing that. Still not working.
I think I may try Arch instead of Raspbian.

Is the distro up to date?