Can't install applications

When ever I try to install applications now i get this “Failed to prepare transaction” message.

“Failed to generate netstandard-targeting-pack-bin information”

I have loosely looked it up a bit, and there seems to be something to do with .NET, but it’s tangled with a bunch of other applications. Is there a way without a re install of the computer to fix this? How can i create log information to locate the specific problem?

We are going to need some more information. What package are you trying to install? How are you trying to install it? What distro is this? Can you paste the full console output that includes that message or a screenshot if you’re using a package store?

1 Like

check which version of .net its using and install it.
there are a few :frowning: so you may have it on your system just not the right one.
much like vcredist and its libraries, multiple versions of .net can be installed.

shit. your on linux… lol… then its a case of installing .net from your the none free.
again check its the right version.
some installers may look for other system components. if you did a recent update the version numbers may have changed.
so look at the installer config and see if its checking for versions of files. if it is. edit the version numbers in the config to match the versions of the files already installed on your system.


Any package that isn’t installed through the terminal get’s this error. Add/Remove Software (pamac) will not let me install anything. If I go ahead and uninstall .NET, it want’s to also uninstall mpv and some other applications. Really strange behaviour.

I have been thinking about re-installing my computer though, because there are some bugs right now that I don’t know how to fix, if it’s even fixable, which surrounds kwin tiling.

I ended up installing three snap packages, .NET 2.1, 3.1. I had .NET 5.0 installed. Isn’t 6.0 out? …

It was and that’s also installed now. I don’t know if it was official though because it had a whole other name then the others.

Seemed like it was.

You are running stuff in a sandbox but is the sandbox configured properly?

I really dont know how to do this but I am a bit weary of misconfigured sandboxes (looking at you OnlyOffice flatpak that wont let me connect to the network printer).

I don’t know.

Can’t remember what I have done to the system in it’s entirety.

I’m a ‘casual’ linux user, I usually fix problems by asking and searching, deadset on never going back to windows in any other shape or form as a VM.

I should look for ways to enhance my knowledge, and I’m pretty sure I want to go back to Arch again, I found that to be the most stable system I’ve used; Arch and Slackware. ^^

Trying to remember when it first started being a problem, I’m bad at logging what’s going on with the computer while it’s running.

1 Like

reading here it seems there are undocumented dependencies.
so give the page a look it might be more help.



netstandard is installed, and when I try to install the community package I get the same error.


Is this a Microsoft error or pamac error? Should I re-install the computer?

To behonest. I actually want to go the VM route, but I don’t have enough GPU’s for that. I didn’t figure out how to get one GPU to work in passthrough for qemu, I tried with an earlier install last year or so. I have been thinking of having a barebone server system and then start up VM’s for my daily drive and game systems, because I just want to have a system that works, and having a host system that I never touch would be a heck of a lot easier, then I could just share harddrives between systems and have multiple clones of them in case I ever came across an error like this. Like a reroll.

I need another 2-3 more gpu’s though, that’s why I’m basically waiting for the new Ryzen 7k series that have integrated graphics, then I will only need 2 GPU’s… Well If I do all gaming on one system, it would only need one gpu, but I want the host system to be untouched.

That was really off-topic. Sorry about that all who read.

you could try the solution here. if it is a pamac error it should then allow the rest of it once fixed.