Can't get into BIOS/black screen when tapping del

I know this is in  the wrong place but at the moment it's not letting me post this into the mobo section. 


I upgraded mobo's about 5 weeks ago from a ASUS M5A 78L-M USB3 to a ASUS M5 A99X EVO, installed the new mobo along with a bigger drive which I had cloned OS on to it, Booted up PC everyting worked fine but I didn't see the ASUS logo on boot all that was there was "jambo control press any key to contiue" did that. everything loaded fine windows worked. installed all the drivers, I restarted my rig to go to some OC, same jambo control came up pressed Del key then there was a flash of colours and it just booted up like normal, so restarted my PC again this time I held the Del key and just got a black screen and nothing loaded. 

Here's what I've tried to fix it: only the MOBO dics in all drives out, everything out of the Mobo execpt CPU and GPU, used another keyboard just in case that was playing up.

This problem is still continuing today, I cant figure out whats playing up, I've been in the ASUS forums they where no help.I don't know if I've forgotern to update/install anything to enter the BIOS 

If you can get into windows try updating the bios(if you haven't already) through the Asus update utility. Might help.

Here's what I would do. Unplug all the data cabled to your drives. Remove all your card except the video card and ram. If  you don't get any beep codes and you do get BIOS it sounds like a video driver issues. If you don't get bios. Pull the remaining cards and reflash it from a USB drive.