Can't enable 3D acceleration in VirtualBox

So here is my problem.

I can't enable 3D acceleration in virtual box. Host is Ubuntu-Mate and trying to run windows 7.

System specs:
Intel I3
AMD Mobility Radeon HD 5470
6GB Ram

I have installed Guest Aditions, the error message is

And on the host I have installed the AMD Graphics accelerators from fglrx-updates.

For any onther info just ask, please help.

LP. David

3D acceleration it is highly experimental on Virtual box. Basically it does not really work thus you cannot actually get 3d acceleration on VBox. I am not sure why you get ivalid setting but even without this you are not missing anything much..

What version of virtualbox are you running? What graphics drivers are you running on the host?

also disable 2d acceleration, thats only available on windows hosts.

Thanks for the quick reply! I'm using VBox v. 4.3.26_Ubuntu r98988. The drivers on the host are AMD Graphics accelerators from fglrx-updates.

Not saying it will help but you should update to 5.0.2 the repo is available on their site

Maybe double check you actually have opengl support by running :

glxinfo | grep -i opengl

So ok got the 5.0.2 VBox same error. When I run the glxinfo i get:

Still no 3D support.

So does the GLXINFO say sompthing about my 3D support? Or am i missing sompthing?