Return to

Can't boot into my live Kali USB! [SOLVED]



Hey there, So I’ve been trying to create a live usb with Kali Linux on it but I can’t boot into it from my computer.

My specs are as follows:
Crosshair V Formula-Z motherboard
Amd FX-8350 @4.5GHz
Gigabyte G1 Gaming GTX 970
Windows 10 Home

I created my bootable USB in Win32 Disk imager using Kali rolling 2017.1 ISO on a 64Gb USB 3.0 Samsung flash drive.
I go into my BIOS to boot from my flash drive, and the kali boot screen comes up just fine.
I hit enter on the “Live (amd64)” option and a bunch of startup text scrolls across the screen, but then my monitor loses signal. The lights on my K70 keyboard and Deathadder mouse stay on like normal, and the internal lights and fans in the PC continue working like normal, but my monitor(s) Say “no signal” and then go into standby mode.

Doing a bit of research, the only fixes I could find were hitting tab on the boot option and entering “nvidia.setmode=0” before booting. Didn’t work.
I also tried the same method with a different command: “grub_gfxmode=1280x1024x24” but had no luck with that either.
That fix as well as most others I’ve seen seemed to be for people attempting to install Kali, not run it from a live USB.

People were saying it has to do with failed hardware detecting because the Kali image doesn’t have the Nvidia drivers installed, which makes sense but I cannot check because none of the computers in my house have integrated graphics.

Any help with this would be wonderful, and I am still a beginner with Linux so verbose advice is greatly appreciated.
Thanks in advance


Have you booted from it before. I would try it on a different computer. And if it still doesn’t work i would try rufus or etcher. I ran kali on my y510p just fine.


I haven’t booted from it successfully before, I just created it today. I agree I need to try it on another computer, but I don’t have access to one tonight so I thought I’d come here for some other potential solutions in the meantime. If I can’t find any other solutions I will try rufus and etcher, but I’m not optimistic that would help because I first created the usb with Universal USB installer, and after having the same issue moved on to Win32 Disk imager, but changing the program didn’t help.


Kali can be very picky on what you make the usb with i have made it with rufus and win32 and they both have successfully made but they both have failed before. I think it might be a problem with the live usb.


Okay, thanks for the tip. I’ll remember that. After a lot of nagging I convinced my brother to let me use his laptop for a bit. I was successfully able to boot into my USB without issue, so now I’m going to attempt to set up persistence and install Nvidia drivers. Hopefully then it will work on my machine. Will update.


I always ran into problems when trying to instal the nvidia drivers. I was following the instructions on the kali documentation website.


Yeah, I just ran into problems as well. I setup persistence and updated/upgraded, and then went to install the Nvidia drivers as specified on the Kali doc website.
After installing those I rebooted and my os pretty much bricked. Before showing the login screen it came to a white screen that said a problem has occurred, please log out and try again. Nothing I tried or found could get me past this screen or to a root command line. Unfortunately since it was a live install I didn’t have GRUB to boot into recovery mode so I could purge the drivers, and the live (amd64) failsafe option got me nowhere.

I ended up nuking that install and re-imaged the USB drive with encrypted persistence. It works perfectly fine on my brother’s laptop, but it still just will not work on my PC/monitors.

I noticed that the point it loses singal to the monitor is the point in the bootup where the scrolling text changes resolution. It generally starts with big low-res text but then switches to your monitors resolution, but that is where mine fails. I tried to wait a bit and then login without using my monitor just by using the keyboard but that didn’t bring anything on to my monitor either.

I guess it’s not a huge problem, seeing as it works on another PC as intended and that’s what it would mostly be used for, but it’s still a pain not to be able to update/install things to it on my own PC. I’m also worried it might fail on other Nvidia based PC’s, so if anyone has any other ideas I’d love to hear them!


instead of using nvidia.modeset=0 use nomodeset instead


Wow, this actually worked! Thank you!


will have to add nomodeset after the install also