Can not load windows after RAM upgrade (SOLVED)

Hello to everyone!

I recently purchased A ram kit (kingston Beast 8GB 1600) . After installing the RAM i could not load windows.After few restarts i finally got to safe mode but i couldn't identify the problem.

In the BIOS settings RAM is identified precisely . I tried to format my drive installing windows from scratch with a USB stick but even this can't load .This is my business PC and i am facing a huge problem. furthermore i had overclocked my PC and i don't know if i messed things up.


ASUS Z87 pro
Intel i5 4690k
Ram 8gb kingston beast 1600
intel ssd
PSU 430 corsair cx

If need it i can provide pictures .
Thank you in advance for your time and effort.

Regards , Stelios

What exactly do you mean by it can't load?
To where in the boot process do you get when you try to run windows normally??

1 Like

First thing is to remove the over clock, save the settings to a profile or write them down.

if still doesn't boot then remove a stick of ram, if boots replace that stick with the one you removed.

1 Like

You may need to update the bios or raise the DRAM voltage. If you bought the RAM individually there may be some compatibility issues.

1 Like

thank you all for the immediate responses . When i say it can not load i mean that when it starts to boot up it takes me to the menu

Launch Startup Repair (which even if i go into i get a Blue screen Of Death)
Start Windows Normally (which after trying to load get me to the exact same menu as above)

I don't know how to undo the OC so if you can be more specific i would appreciate it

Replacing the RAM was the first thing i thought of but even then could get into windows..Safe mode only but i can't get to it now.

The blue screen says that the system has encountered an uncorrectable error.By now i am downloading ubuntu hoping i can flash it and see what is what.

the DRAM voltage is set to auto i think.
Sould i get to BIOS and help me from there?
Any recommendations?

So it doesn't even boot with the original ram now?

if that is true only thing i can say is to reset the bios to factory settings. to do this there should be a section to exit the bios in there it should say save and exit, a few other options and then should have reset bios, or set default settings and exit.

if that doesn't work something may have fried, the first bit of that error code is general failure

I had that error the 0X000000124 when my motherboard died (may not be the same issue for you) and it would blue screen to that error when ever you put load for a bit on the gpu.

1 Like

Thank you all so much.Finally i got it running again..
Changed BIOS Setting to default (stupid me how didn't i think of that)
Everything running smooth again.
Playing with BIOS OC was a mess for my PC..(noob)

Thank you all for you time!

Cool, you should add solved to the title of your thread so people know.