Return to Level1Techs.com

Building a Custom File Share (Raspberry Pi and OMV)

I wanted to update and share my latest creation. I posted a while back about looking at purchasing a NAS found here in my “Original Thought Process”

So I want to thank everyone for your input as I thought I had my mind made up to purchase off the shelf, but I made the plunge to build a DIY home server with a RaspberryPi at its core.

I first built up everything in a shoe box to get Raspian installed and hopefully get a file share configured.

Obviously the NAS couldn’t stay in the shoe box. I had my grandfather’s M1 ammunition can from WWII sitting around gathering dust and thought it would be a neat little tribute to him as this can will literally be storing our family’s memories for the foreseeable future.

Unfortunately I was unable to get Raspian to act as a network share. I was derailed trying to use Netatalk and some other ancient Apple protocols because I wanted to create a “Time Capsule”…meh…I could have turned back and started from scratch. However, I stumbled across Open Media Vault (OMV) and decided to give it a shot. I ended up liking the interface and it was definitely more noob friendly, though I recognized most of the Web GUI steps from my few attempts at the command line.

I then got everything wired up to my Meanwell 5V 5A power supply so I could deal with a single power cord and not a bunch of “phone chargers.”

!

Lastly, I placed everything into the ammo can, hacked out a few cut outs with a dremel, added a second hdd for backup/snapshots, and velcro’ed a stand alone SSD to be used for quick transfers (check out that USB-C port! *screws pending)

I am pretty satisfied with how everything turned out. It is a bit cobbled together and the write speeds are quite slow @ 6 MB/s (will probably engage the community for some help) But as of right now, I have a simple file share in a cool little package where the whole family can now access and save files at home.

7 Likes

This is likely due to either the usb 2.0 bandwidth limitation, that the nic is tied off of. I don’t know that you’ll get better performance from a Pi.

1 Like

I agree on that. I have a similar set up (however, no cool ammo case for a case) and the best I can get on even a SSD is about 6.5 MB/s at the very best.

1 Like

You’re going to be severely limited by the Pi. Don’t use a Pi.

Could use an Odroid XU4, the Cortex-A15 cores should pack quite a bit more punch.

I used OMV and a Pi 2 SMB share for quite a while and I mostly maxed out the transfer speeds of the 100Mbit NIC.
What filesystem are you using on those drives? I’ve always used ext4 and never had slow transfers. NTFS adds way too much overhead for the Pi.

2 Likes

The idea of having this in something that will remind you of your grandfather is awesome. Yet another wonderful bit of creativity show on L1T today. Congrats on the finished product and even if it stayed the way it is even if it underperforms or whatever great stuff.

1 Like

Using EXT4 here so yeah not exactly sure what is causing the choke hold. I have browsed a couple forums regarding OMV and most people with trottle issues experiencing sub 1MB/s on full-fledged systems or read/write would start out 80-100MB/s then crash in speed and their solutions were either a .conf change or kernel update. I just am at consistent 6 MB/s.

I know I am running the latest kernel, and the couple tweaks I have tried to the config file so far have not resulted in any changes.

Do you know if you made any changes to power delivery? That is one thing I haven’t tried yet. I have only configured for disks to not spin-down.

@sgtawesomesauce I believe was correct. I think we both hit our saturation limit of the NIC. I re-read and noticed you mentioned 100 Mb not MB. So my writes at 6.5 MB/s or 52 Mb/s is about correct.

I then pulled this chart from jeffgerling which confirms what we were all saying.

A bit of a bummer, but honestly once I get all my bulk data migrated, the 6MB/s is not a deal breaker.

Still your speeds are “slow” for a Pi 3B. I’m running the integrated overclock profile on mine, but that doesen’t make it faster than your Pi (mine is a Pi 2). I think the “issue” might be that you’re accessing multiple drives for different stuff at the same time.
My suggestion is to power it down, boot it up with a single drive and try a copy. I’ve always used mine with just one drive at the time (even a PATA USB 2.0 drive) and, through ethernet, always reached the maximum speeds so I don’t see why you wouldn’t.
Also check the parameters in the drive mount (fstab) and SMB (you can enable some through OMV too).
One other thing that comes to mind is that I’ve had some issues even seeing my SMB share on some late releases of W10. If you’re running Windows you should try doing a transfer through your phone or a different OS.

I can’t think of much else that could be the culprit of your issue. I’ve only experienced slow speeds (and crashes) using wi-fi dongles. Looks like my Pi doesen’t like sustained transfers through wi-fi.

2 Likes