Bridge Interface created, host no internet

I’ve created a bridge using virt-manager.
The Windows 10 guest has an internet connection, but the host doesn’t.

/etc/network/interfaces is as follows (virt-manager added br1):

auto lo
iface lo inet loopback
auto br1
iface br1 inet static
bridge_ports enp7s0
bridge_stp on
bridge_fd 0.0

Pings to/from guest, host, and other local computers all work. It’s just the host machine that doesn’t have an actual internet connection.

I tried adding the following to br1 but it doesn’t work.


Again, the guest does have internet. It is the host that does not.

I’m suspicious of the lack of a netmask; and that could easily explain the host being able to communicate to the guest but not the internet. My interfaces looks like :-

iface br0 inet static
    # Controlling the bridge.
    bridge_ports enp5s0
    bridge_fd 0

Could also be your firewall settings, in this case your DHCP client and all connectivity on the host is supposed to run on the bridge (or something along those lines, not sure how your network was originally set up).

@VeryZ Have you tried creating a bridge using the virt-manager GUI?
netmask, network, and broacast are not created by default if I use the GUI.

They also haven’t fixed my issue.

I suppose my main question is, are you supposed to lose internet connectivity once you configure an interface as a bridge?

Using DHCP on the bridge allows internet access on host and on guests.

I decided to see if I could get static IP to work on a standard non-bridge interface, and that didn’t work either.

Could it be possible that the router work with my machine? I’ve been able to set static IPs on other windows computers on the network with no issues.

When it comes to this machine however, the only thing that worked was using a DHCP Reservation on the router itself.

Nope. Not used that. But it looks like a networking issue to me, although as I’m paid to look at networking issues there’s a bit of confirmation bias creeping in.

So a dhcp assigned address works when static doesn’t? Things to try :-

  1. Drop the ‘bridge_stp on’; I doubt this has anything to do with it, but STP can quite easily bite you on the arse.

  2. Double-check that the static IP isn’t within the range that DHCP uses for dynamic allocations.

  3. Ping the gateway address ( and ping

  4. Show the output of “ip addr show dev br1”

  5. Show the output of “ip route show”