Booting Linux on Intel Optane

Hi new user here. Been a fan of Wendell for a long time. Long time Linux user as well(as far back as debian 3.0 on Old World powerpc macs - BootX anyone?) Tho i still do not consider myself an expert… only a power user.

Anyway on to the topicat hand:

I see many posts on here and other forums about using Intel Optane products as caching drives either for l2arc on freenas or Bcache on linux systems. But I do not see anyone talking about using them as a boot drives. My new desktop build is a ASRock killer sli/ac x370 running a mild OC’d Ryzen 1700.

Got a good deal on a 32gb Optane m.2 nvme and decided to use it as a boot drive. Drive metrics may not be the best but are immensely faster than the 8tb WD Red that I was using temporarily.

Reasons I used Optane as boot:
Optane does not write block for block like nand flash and as such does not use the TRIM command. Using LUKS with a regular SSD and running trim could possibly expose security risks. So it pretty much acts like spinning rust only much faster.

/home partition is on 1tb WD Blue encrypted with LUKs as well using JFS as my fs of choice there as well
10gb of swap is also on the same spinning rust but the chances of needing it with 32gb of DRAM are slim.

Total boot time from pressing the power button to autologin on xfce pausing at LUKs password entry went from 120 seconds to 40 seconds. Chrome also loads nearly instantly right after boot.

for only $45 I think this was a huge improvement. Write endurance hopefully holds up?


Woah. Mind blown.

I had no idea you could take intels Optane, the non ssd optane, and put an os on it.

Can you install any OS on it?

I was under the impression that it was just another M.2 NVMe device, so I’d guess yes, but I’ve never used one so maybe not.

1 Like

I would imagine any UEFI aware OS would install on it. Drive space permitting that is. I imagine only Linux or *bsd would be small enough to fit. This setup only worked for me because my /home and swap are on a different drive.

1 Like

Maybe try btrfs with zstd compression enabled, I’m curious how much space you save.

So last night I was just doing some googling and the amount of people that said that this wasn’t possible was huge. I did see one video tho of someone booting Windows 10 off of it, in like 8 seconds.

I also tried to find benchmarks of just the drive itself, but wasn’t able to find a lot of them. And it’s been about 8 hours since I seen them. But I believe it hits 100mb on qd1t1. Which is really cool.

Is that super impressive? My Intel “gaming” NUC with a 960evo will do that happily from cold. It would expect something more if they are charging for the little amount you get.

1 Like

I thought it was impressive. lol. I have not really looked at ssd boot up videos.

I mean it is impressive, but it is not really an advancement in terms of boot times as far as I am aware. And consider how limited optane can be on space and price premium you pay for the speed.

I am sure in the correct applications it is very fast. But if that is what it does as a boot device there are probably better places to use it.

1 Like

People that fell for Intel’s bs market all do. They are just ssds

I believe Intel did marketing like that b/c windows users cannot use it for their OS drive.

1 Like

Can I ask your process to install? I have an HP laptop that I was wanting to dual boot with. I disconnected the optane drive in the Intel fast storage app and formatted it as fat32. Windows will read it as an empty drive. It’s set as non raid in BIOS but still when I boot with my USB it is nowhere to be found. I’m trying to install Mint 19.1.

did you ever find the answer? i’m in the exact same boat trying to sail the same route! how do you get the optane drive to appear as an installation option?

Replying to an old thread.