Return to Level1Techs.com

Blender EEVEE Rendering Help With Tesla M40 GPU's

I’ve been working on an API written in GO that uses Blender to render STL files as thumbnails image previews for my web application. I’ve been running into issues with the two Tesla M40’s I have at the moment.

nvidia-smi:
image

As we can see so far nvidia drivers are setup correctly and the gpu’s are seen but I seem to be running into issues with blender specifically wanting a display to enable OpenCL support for the EEVEE rendering otherwise the program just exits.

I ran into sort of a solution but am having trouble following the correct setup procedure.

EEVEE and Cycles differ in the way they use and need a GPU. EEVEE always uses OpenGL and can’t work without it. But Cycles’ GPU rendering mode is based on CUDA and doesn’t need OpenGL. Therefore, GPU-based Cycles rendering (through CUDA) can be used without have an X server running.

Any help is appreciated It seems I just need help setting up the XORG server to have the display’s using the Tesla M40’s and can prepend my blender starting arguments with DISPLAY=:1.0 to force it run on that display using the M40.

does the system have a head? (monitor plugged in) and what gpu is it plugged into, Aspeed GPU might not cut it

The system is running Headless no monitor is attached I should have been more specific with the setup I have Proxmox running all my Ubuntu Server vms with the Tesla M40’s passed through.

I also seemed to resolve this issue regarding the EEEVEE rendering from this guide here I can’t post links but for those who have this issue and are also looking for a solution google “how-to-get-blender-2-80-to-render-through-an-ssh-connection-minimal-working-ex” to find the article you need.

Link As Per Mod: https://blender.stackexchange.com/questions/144083/how-to-get-blender-2-80-to-render-through-an-ssh-connection-minimal-working-ex

It seems that you need to initialize the nvidia-xconfig with the GPU you want to use.

I was thinking you might have needed a head to a opengl compatible gpu to make it work but hey you got it working

try posting link again, if you can’t let me know