BIOS update now my PC does not boot into even a live CD due to missing intel-microcode... What can I do?

I tried to update the BIOS on a Gigabyte X99-UD4 (rev. 1.1). I flashed the newest version I could find but apparently something went wrong because now my Linux system (PROXMOX VE 7) does not boot and hangs with a strange error – something something agp and scheduler…

When I try to boot a livedisk it errors when booting linux stating that my intel-microcode needs to be updated. How would I do that in those circumstances… is there a trick? Since the one included in the BIOS seems to be too old…


– who has not the faintest clue about BIOSes/UEFIs…

Likely secure boot setting, have you tried legacy or can settings

i know on my asus x570 board it’s listed under boot options as either windows uefi or other os.

If you can enter the BIOS you can try re-installing the update. Also, you can try to reset the BIOS or remove your BIOS battery for a while and then try again.

Those settings do indeed exist but nothing seems to fix the issue. Since I obviously can’t ssh into the machine at this point I have attached photographs of the various errors:

  1. Trying to boot into Proxmox VE 7 (on the SSD)
    Google Drive: Sign-in

  2. Trying to boot a linux live CD (Proxmox VE 7 ):
    PVE livecd boot.jpg - Google Drive

Nevermind, I might be a moron:
I needed to specify EXACTLY what CPU I was using in the BIOS/UEFI and then it just worked again. Probably the Auto option just didn’t work properly after the firmware update. I don’t know why though.

Kind of a wasted week. But I am glad at least that’s solved.
Thank you @GigaBusterEXE, @Azulath and @thetazman :slight_smile:

1 Like

Glad you got it sorted out.

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.