Bios dose not work

I can’t get into the bios.

If I start the computer everything works fine

  1. Mainboard screen (press Del for Bios)
  2. Windows startes up.

So everything seems fine.

But if I press Del to get into the Bios the screen dose not show it. It sort of just stays gray (so it still has connection to something)

Same happens if I press F8 (I think it is change Boot device. If I restart the PC everything is fine again.

I tried:
-Disconnect the PC from power
-Remove CMOS Battery (And shorting the socket)
-Every Displayport on my GPU and USB C to HDMI

My System:
CPU: AMD Ryzen 7 3700
MB: ASUS X570 TUF
GPU: NVIDIA RTX 2080

How can I fix that?

I want to activate TMP for Windows 11

Try a different USB keyboard plugged into a top, rear USB port (near PS/2 port).

1 Like

I wonder if your display is acting up on the BIOS screen, i.e., not liking the resolution and/or refresh rate that the BIOS screen is trying to output.

Maybe try another display if possible.

Also is your display an HDMI ONLY or does it also have displayport inputs and/or old skool VGA as well ?

Could try a different input port and see what happens.

2 Likes

Yea and sometimes I’ve seen them default to the onboard graphics card vs a dedicated graphics card.

^^this, I forgot about this one too however the 3700/3700x is a CPU only.

On Windows 10+ you can LEFT-shift +left-click on restart and access a menu that goes troubleshooting->advanced->restart into UEFI or something like that. I do this anytime I’m too lazy to look up how to get into specific OEM BIOS.

3 Likes

you have fast boot or ultra fast boot on, do what E-wasted suggested and it will boot into your bios, there you can disable fast boot

1 Like

try using the boot menu…
start windows,
hold shift key and and restart the computer from the start bar.
the system should start shutting down then go to the blue menu screen where you can select troubleshoot/open bios or eufi.

once open find fast boot and disable it. save and restart, you should now have access to the bios via delete at startup.

AMD Ryzen 7 3700 has no APU

Now it stopped working all together. So I tried removing the battery and reset cmos. Then it bootet 1 time to the post screen. Now everything stayes black.
I additional tried:

    1. Screen (With new cable)
  • using onboard display out ports.
  • using other GPU
  • using HDMI on 1. GPU

I really don’t know what to do.
What is my best bet wich part is bricked? CPU or MB?

Do you have another mb to test the cpu / memory / video card in in? Or a friend with one?

I have a 2700 laying somewhere
I’ll try this next

Remove storage device and it will force into bios

1 Like

did you flash the bios at any point?
if so which one. and did you follow amd’s instructions on updating the chipset before you update the bios.
you will brick the motherboard if you didnt perform all steps.
if its bricked then rma is all you can do unless your board has a plug in bios chip.

I may have downloaded the newest firmware from the Asus webpage. But why did it work at first then… Wouldn’t that brick the whole boot process?

i just looked and it seems asus bundle there firmware with the bios updates (unlike gigabyte)
so updating the bios shouldnt be an issue.

as its a black screen boot.
turn the computer off at the front.
pull the battery. turn the pc off at the brick and quickly short the terminals in the battery housing.
the residual current in the motherboard should be enough to clear it.
after 10 seconds or so put the battery back in. power the brick, and turn it on at the front.

hopefully the old method of clearing the cmos will work.
if not then try putting a new version of the original bios on a usb. and flashing back to the one it shipped with.

on reboot the system may take a minute or 3 to learn the memory profile and hardware.
so if it reboots or appears to hang.
try leaving it for a little bit (not more than 2 mins).
if still nothing. hit reset and let it try to boot again…
then one more time…
after 3 (max) reboots all hardware should be detected with luck.

if not i would assume the bios bricked. and its time to talk to asus. they are helpful

Or loop checking for bootable media…

I send the MB back to the seller… waiting for a replay. Dismantling it I killed the CPU, so I can’t test everything anymore.