B450 system won't post with 3600

so I just ordered a new build. its a ryzen 5 3600 but I did opt for a b450 board to save some money. its the aorus pro wifi board and it says there is a bios version to support ryzen 3000. the system won’t post. The aorus light flashes when i turn the power-supply and when i push the power button all the fans spin and it looks like it should work but nothing on the screen. the dram light on the board is on and every 10 seconds or so it flashes off the CPU light flashes on and the then just the dram light. I’ve tried pulling out each ram dim and using on ram dim in every slot. then I tried re-seating the CPU. I’ve tried my old graphics card the clear cmos a different monitor now I’m out of ideas. If its an old bios that is preventing it from booting do i need to track down a 2000 CPU to update it or does anyone have any ideas

1 Like

Pretty much this.
AMD offers to lend you a CPU to do the upgrade:
Or, you can look into buying one of the cheapest Athlons at 40 odd bucks. I’m pretty sure, Gigabyte doesn’t have an option to flash the bios without a CPU. That’s the main reason i went with MSI for my upgrade…


I gave the manual a once over and it looks like it doesn’t have any kind of bios flashback, you can try and see if a local computer shop will flash your bios for you, I think you have to flash it twice due to gigabytes dual bios implementation but I’m not sure


thanks I went to a shop and they loaned me their bios update cpu for $15 and I got it all sorted.


Solved :slight_smile: