Return to Level1Techs.com

B450 Aorus Pro Bios Downgrade to F1 PC not responding

Hello everybody ,

I jsut made a gaming coputer not high budget and since i install everything all worked just fine . After a day of use my motherboard stop reading on the pcie x16 my Gpu . On all other places worked fine beside the pcie x16. I tried everything even send motherboard back to the store for check and told me its working just fine. So i try to downgrade the bios from F50 latest version to F1 cuz i though thats how motherboard default settings are… big mistake … since then when i start pc i have black screen all fans works on full and nothing more …

Computer specs are:

PC case : CoolerMaster Masterbox MB500 TUF Gaming Edition

MOBO : Gigabyte B450 Aorus Pro

CPU : CPU AMD RYZEN 5 3600 3.60GHZ

RAM : G.Skill RipjawsV 16GB DDR4-3200MHz (F4-3200C16D-16GVKB)

GPU : Gigabyte GeForce GTX 1660 6GB Gaming OC

PSU : Thermaltake Smart RGB 700W

Please if you read this i would be extra happy to recieve an answer. Thanks a lot in advance and stay safe with Virus!!!

hate to break it to you but bios downgrading is not supported. It even says not to do this on their website as it can break things.

Your only hope is check that your Mobo has a dual bios you can switch to. If it does not then you’ll need to buy a new motherboard sorry. Good news is that if it is still within warranty then the manufacturer will be able to help you get a replacement.

Good luck!

Maybe when you know somebody with a Ryzen 1000 or 2000 series cpu,
you might be able to boot the board again when lucky.
Then you can update the bios to the latest version.

But like @Dynamic_Gravity already pointed out,
in a worst case scenario you bricked the bios.
And then you have to rma the board.