Return to Level1Techs.com

Avermedia DarkCrystal HD Capture Pro - C027 on Linux

Hello my Linux juggernauts. I’m calling out for help once again. This time it’s with my Avermedia DarkCrystal HD capture card. I’ve been searching high and low trying to figure out on how to get this bugger working. I’m currently experimenting in Ubuntu 18.04 right now, but I will be switching back over to Manjaro once i figure this issue out. The Linux kernel does pick the capture card up

06:00.0 Multimedia video controller: Device 1a0a:6202 (rev 01)

According to Kernel Labs, it is compatible with a wide variety of applications. Only thing that picks up in the listed application is my Logitech C920.

I’ve tried using ndiswrapper to install the Windows driver, but to my luck still didn’t detect, but I think that only works with NIC drivers.

Update: So I did a deeper look on the card itself and found the chip it6604 on it. Went to google on it6604 linux driver, found the github for it. Now new question, how do I compile it using Manjaro 19.02?

Read the makefile on the GitHub repo. Hasn’t seen an update in 4 years though so it appears to be unmaintained so best of luck.

Typically you need to do make in the source code directory where the makefile lives and then a sudo make install usually does the magic from there.

When I run make, I get this as the output

Makefile:4: …/…/Makefile.param: No such file or directory
make: *** No rule to make target ‘…/…/Makefile.param’. Stop.

We’re there specific instructions to compile the driver? Did you cd to within the directory of the makefile?

I took a closer look at the source files and I don’t think this repo is what you’re looking for. It appears to be malformed.

What are the possilities of fixing it? Granted something like that would be REALLY over my head.

Unfortunately, really the only cards that are fully Linux approved are Magewell and Blackmagic cards. I would avoid USB 3.0 based UVC ones and go straight for PCI-E ones. UVC is a webcam standard and does not include native support for drop frame framerates. If you see a 59.94fps in an OBS dropdown, that means the destination is only grabbing at that rate but the capture on the UVC device is 60.00fps. This unfortunately doesn’t always work in practice.

PCI-E cards maintain the correct capture frame rate throughout the chain if no scaler is applied.

That’s what I thought. I do know Hauppauge would be another option as well. I know their HD PVR 2 USB capture card does have a Linux driver to download from their site. Granted it’s for Ubuntu based Linux Distro’s but might be able to find the same ones in the Arch Repo